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1. Welcome to NIS-Elements AR documentation.
This help file describes capabilities of the NIS-Elements AR laboratory image analysis system. Chapters and
paragraphs marked by the following symbols describe features available only if certain module or device
was installed.

(-A1- option)
Requires the [Nikon A1 Confocal Microscope] device.

(-DB- option)
Requires the [Database] module. See [Database].

(-DEC- option)
Requires the one of the [Deconvolution] modules.

(-EDF- option)
Requires the [EDF] module. See [Extended Depth of Focus].

(-FRET- option)
Requires the [Calcium and FRET] module.

(-LO- option)
Requires one of the [Local Option] features to be installed. See Step 2.

(-MET- option)
Requires the one of the [Metallography] modules.

(-NDA- option)
Requires the [Advanced ND Acquisition] module

(-TR- option)
Requires the [2D Object Tracking] module. See [Tracking (-TR- option) ].

(-6D- option)
Requires the [6D Acquisition] module
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2. Installation and Startup

2.1. NIS-Elements AR Installation

Quick Start

• Insert the installation DVD in the DVD-ROM drive. A window automatically appears.

• Install the selected NIS-Elements AR software version, additional modules, and device drivers.

• Plug the provided HASP key into the USB port of your PC.

• Run NIS-Elements AR

The Installation DVD-ROM Content

The installation DVD-ROM contains:

• NIS-Elements AR software setup file

• Drivers and utilities for the HASP Key

• Drivers for selected cameras

• User's Guide in the PDF file format

• Sample image database

• Sample ND2 image sequences

The Installation Process

Note

You have to possess the administrator rights to your computer to be able to install NIS-Elements
AR successfully.
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1) When the installation DVD is inserted, a selection window appears automatically.

Select the software package to be installed. Select the one you have got the license for and which is
properly coded in your HASP key. The installation wizard welcome-window appears. Click [Next] to
continue.

2)

Select whether to install [Local Option] or not. Define the folder where NIS-Elements AR should be
installed. We recommend to use the predefined directory. If you want to change the directory anyway,
press the [Browse] button and select a new one. Otherwise click [Next].

Note

The [Local Option] installation provides some advanced features which did not pass the
quality assurance procedure yet. We recommend to wait until they are released officially.

4

NIS-Elements AR



3)

Now, select the cameras which will be used with NIS-Elements AR.
4)

If your licence contains some additional modules besides the NIS-Elements AR core software, please
select them in this window.

Note

Any module selected will be installed along with NIS-Elements AR automatically. However,
you might not be licensed to use it. The module will run after you get the corresponding
code registered in your HASP key.
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5)

Select the devices which will be used with NIS-Elements AR. Finish the installation by clicking the
[Install] button.

6)

The setup creates a new program group in the [Start] menu containing the following items: NIS-Ele-
ments AR application shortcut, the HASP key information shortcut, the [Modify Installation] shortcut
(for adding hardware drivers, modules, etc.), the [Uninstall] procedure, and the Send Info Tool. A
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shortcut to NIS-Elements AR is created on the desktop too. These changes affect all user profiles of
your local Windows operating system.

Note

Clicking the [Uninstall] command deletes all installed files from disk, and removes the NIS-
Elements AR program group from the Start menu as well as it removes the desktop icon.

Additional Module/Device Installation

Youmay need to install a device or an additional module after the NIS-Elements ARmain system installation.

• Go to [Start menu > Programs > NIS-Elements AR] program group.

• Select the [Modify Installation] command.

• Follow the installation wizard instructions. Select the check-boxes by the items you would like to add.

• Finish the installation.

Sample Database Installation

If you chose to install the Sample Database, a new subdirectory “Databases” is created inside the NIS-Ele-
ments AR installation directory (e.g. C:\Program files\NIS-Elements AR \Databases\...). The “Sample_Data-
base.mdb” file is copied to there along with database images (stored in subdirectories). An administrator
username/password to access this database is set to:

• Username: "sa"

• Password: "sa"
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The software Copy Protection

The NIS-Elements AR software is delivered with a HASP hardware key.

The HASP key contains information about the software licence and allows users to run the corresponding
software. Please connect the USB HASP after the NIS-Elements AR installation is finished. The utility called
HASPinfo is installed to the NIS-Elements AR directory. It enables the user to view information about the
software licence and is accessible via the [Help > HASP Info] menu command.
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2.2. Command Line Options
When starting NIS-Elements AR from the command line (or when editing the desktop shortcut properties),
you may append some parameters to the main command and thereby modify the startup behavior:

2.2.1. Syntax and Example:
“ NIS-Elements AR executable” [switch#1] [parameter#1] [switch#2] [parameter#2] etc. For example:

“C:\Program Files\NIS-Elements AR \NIS-Elements AR.exe” -f “C:\Images\starting_image.jp2”

This command runs NIS-Elements AR and opens the [starting_image.jp2] at the beginning.

Note

• By default, only one instance of the application is allowed to run. When the application is running
and a command similar to our example is called, it will be applied to this running instance. This
does not apply when the [-q] switch is engaged.

• Some switches do not have parameters.

2.2.2. Switches:

-?
Displays a help screen with the description of switches.

-c “Command”
The application runs the specified internal NIS-Elements AR command.

-f “Filename”
The application tries to open the image pointed to by the [Filename] parameter.

-g “Grabber name”
The image grabber (driver) of the specified Grabber name will be used and no camera-selection window
will show at startup. As the name of the grabber, you can use the name which appears in the startup
driver selection dialog, or the name of the driver class. These are listed in Windows registry
(HKEY_CURRENT_USER):

“Software\Laboratory Imaging\Platform\Platform.INI\CLxGenericProviderGrabber”

Set the parameter value to “last” and the most recently used grabber/camera will be loaded.

-gn
No grabber driver will be loaded. The “passive” version of the software will start.

-h “HW Unit Name”
The specified HW Unit will be used. Two HW Units (e.g. two DS-U2 cameras) can be run by one grab-
ber/driver. The available HW Units are listed in the [Acquire > Select Camera] window. Set the para-
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meter value to “last” and the most recently used HW Unit will be loaded. When using this option you
must also use the [-g] switch.

-i “Config Name”
The application creates a registry entry in "Laboratory Imaging\Platform\Config Name" to load from and
save its configuration to.

-s “Settings File”
The application will use the specified Settings File to load and save its settings.

-l “Language”
The application will run in the specified language (if available). Use codes for the names of countries
according to the [ISO 3166-1] standard.

-m “Macro File”
Application will execute the macro file (*.mac) pointed to by the [Macro File] parameter.

-passive
The application will not connect to any device on startup (NIS-Elements AR will start with blank Device
Manager). Camera selection is not affected by this option.

-p “Position”
The application window will be placed according to the parameter:

• [left] - the window is placed on the left monitor.

• [right] - the window is placed on the right monitor.

• [top] - the window is placed on the top monitor.

• [bottom] - the window is placed on the bottom monitor.

• [monitor N] - the window is placed on the Nth monitor.

• [rectangle (x0,y0,x1,y1)] - the window is placed in the specified rectangle (in workspace coordinates).
The coordinates must be in parenthesis without any spaces.

-q
A new instance of the application will run.
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3. Application Appearance

3.1. NIS-Elements AR Screen
The following items can be found within the NIS-Elements AR screen:

• The top [menu bar] containing pull-down menus with sets of commands.

• [Application tool bars] (left and top) where buttons representing variousmenu commands are gathered
for quick access.

• The [status bar] displaying useful information.

• [Document tool bars] (right and top) which enable to customize the view of each opened image individu-
ally.

• Docked or floating [control windows] - seemore description of docking windows in the [Modifying Layout]
chapter.
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3.1.1. Menu Bar
All commands sorted according to their purpose are placed in the following menus:
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Standard screen

File
Concerns operations with files such as Open, Save, Import, Send, etc.

Edit
Concerns operationswith the current document. Copy, Paste, Undo, General Options and other commands
are available.

Acquire
Concern image acquisition.

Calibration
Concerns document/objective calibration and optical configurations.

Image
Concerns operations with images, color transformations, resizing, etc.

Binary
Concerns operations with the binary layer - contains thresholding and morphology commands.

Measure
Concerns manual and automatic measurement.

Reference
Concerns operations with reference images. To display all reference images, use the [View > Thumb-
nails] command.

Macro
Concerns user macros, macro creation, etc.

Database (-DB- option)
Concerns database connections, database tables, database backup etc.

View
Gathers commands concerning the appearance of the screen, displayed control windows, zoom, etc.

Devices
Contains commands needed to handle all connected devices (except cameras).

Window
Concerns opened document windows. It enables to select a window to be displayed or select a predefined
windows documents layout.

Applications
Gathers commands of additional modules if there are some installed.

Help
Enables access to additional information about the system such as help, HASP Info, application log,
etc.
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Organizer

In [Organizer], most of the menus are hidden, but the following is added:

Tools
Contains commands for filtering and sorting images.

3.1.2. Application Tool Bars
There is a default set of tool bars each containing number of buttons. There is also one fully customizable
tool bar - the main left tool bar - to which any button can be added (or removed from it). Every button or a
tool bar can be hidden by user using the [LayoutManager]. Please see [Modifying Layout] for further details.

3.1.3. Status Bar
The status bar at the bottom of the screen displays the following information:

The Application Status Bar

1. Available layouts (you can hide the layout tabs by de-selecting the [Edit > Options > Appearance >
Show Layout Tabs] option)

2. Type of the current camera

3. The most recently performed command, or the FPS/Exposure info in case of live image.

4. Name of the current objective.

5. Current coordinates of XY(Z) stage.
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3.1.4. Document Window
Tools affecting the appearance of the current document (image) are gathered within the document tool bars.
Although tool bars can be customized, the default ones contain the following buttons:

LUTs

• [Enable LUTs] button applies LUTs to the image. See [LUTs].

• [Keep Auto Scale LUTs] button applies the AutoScale command to the image continuously.

• [Auto Scale] button performs automatic setting of LUTs.

• [Reset LUTs] button discards the LUTs settings.

• [Show LUTs window] button opens the window with LUTs.

• [Pixel Saturation Indication] button turns on/off pixel saturation indication without setting on/off
LUTs. Select the highlighting color from the nearby pull-down menu.
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Split Components

• [Split Components] button turns ON a special view, where color channels of the image are displayed
separately (tiled).

Zoom Controls

• [Fit to screen] button adjusts zoom to view the whole image within the NIS-Elements AR screen.

• [Best Fit] button adjusts zoom to fit the NIS-Elements AR image window in one direction but to fill
the screen.

• [1:1 Zoom] button adjust zoom so that one pixel of the image matches one pixel of monitor.

• [Zoom In] Increases magnification of the image.

• [Zoom Out] Decreases magnification of the image.

General Controls

• [Show Probe] button activates the probe. The probe affects histograms, auto exposure and auto
white balance functions.

• [Show Background Probe] button activates the background probe. Some commands use the BG
probe data as reference.

• [Show Grid] button displays the grid for rough measurements.

• [Show Scale] button displays the image scale.

• [Show Frame] button displays and applies the measurement frame.

• [Show Measurement ROI] button displays the Measurement Region Of Interest.

• [ShowProfile] button displays the [View>Analysis Controls > Intensity Profile] control window.
It allows you to specify a linear section in the image of which the pixel intensities graph will be created.

• [View LUT Intensity] button displays the scale of intensities used inside the image. It works on
monochromatic images or a single image channel.

• [Show Annotations] button displays the vector layer which typically consists of annotation objects
(text labels, arrows) and measurement objects.
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• [View Binary] button displays the binary layer of the document.

• [View Color] button displays the color layer of the document.

• [View Overlay] button displays the color layer and the binary layer in overlay.

Tip

Right click the icons to invoke a context menu where properties of each tool can be modified.

Status Bar

The status bar at the bottom of the document window displays the following information:

The Document Status Bar

• Image calibration

• Pixel coordinates of the mouse cursor along with channel intensities

• Color mode (RGB, Monochromatic, etc.)

• Image bit depth (8bit, 12bit, 16bit, etc.)

• Image size in pixels
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3.2. Modifying Layout
Having a well organized application layout can help you make the work with NIS-Elements AR very effective.
The live image, image documents, various control windows (Camera Settings, Measurement, Histogram,
LUTs, etc.) can be arranged within the application window. The control windows as well as tool bars can be
floating or docked on sides of the screen. Multiple monitors setup is also supported. User commands may
be added to the main menu, and tool bar buttons may be added/removed.

3.2.1. Layouts
A layout in the context of NIS-Elements AR is a set of options describing the arrangement of control windows,
tool bars, and menu items. Blue tabs representing active layouts appear in the application status bar. The
following layouts are placed there by default:

• [Full Screen]

• [Docked Controls]

• [Measurement]

Other layouts can be added and managed via the Layout Manager. To hide/show the layout tabs within the
status bar, go for [Edit > Options], select the [Appearance] tab and (de)select the [Show Layout Tabs]
option.

To Create a New Layout

• Modify the current layout so that it suits your concept of work.

• An asterisk [*] appears next to the layout name (to indicate it has been modified).

• Right click the layout tab and select the [Save Current Layout As] command. If you do not need to create
a new layout but would like to save the changes made, just right click the current (asterisk-marked) tab
and select the [Save] command from the menu.

• Write the new layout name and confirm it by [OK].

• A new tab appears and the layout is saved to the list of layouts.

To Reload Previous Layout Settings

You may want to undo the changes made to the layout. Mostly, it can be done by the [Reload] command.

• Right click the asterisk-marked (recently modified but not saved) tab and choose the [Reload] command.
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• The application restores the last saved state of the layout.

3.2.2. Layout Manager
Call the [View > Layout > Layout Manager] command. The Layout Manager appears.

3.2.2.1. Layouts
The list of currently available layouts is placed on the left side of the layout manager. Each layout may contain
information about controls, tool bars, menu, and commands to be performedwhen switching between layouts.

The List of Layouts

Modifying the Layout Settings

• Select items within the [Global Layout] list which you want to be shared by all layouts.

• The check marks on the left of the layout names indicate the layout visibility. Select the ones you want to
display in the application status bar.

• If an item within some particular layout is not selected, it means you do not want to customize it and the
global settings - if selected within the [Global Layout] - will be used. If the item is not selected within the
Global Layout either, the settings of the most recently active layout will be used.

• Set whether the layout is [Private] or [Shared]. If set [Private], it will not be visible for other users. See
[User Management].

• Customize each item according to your needs (see below).

Layout Manager Tools

• The [New] button adds a new layout to the list of layouts.

• The [Remove] button deletes the selected layout. The first two layouts cannot be deleted.
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• The [Activate] button makes the selected layout active

• The [Load Default] button loads original settings of the selected pre-defined layout ([Full Screen],
[Docked Controls], [Measurement]) so that it looks just like after the program installation.

• The [Apply to All] button ensures that the executed changes will be applied to all layouts.

• The [Import] button enables to load a previously saved set of layouts from an XML file.

• The settings of all layouts can be saved to an external XML file. Use this [Export] button and define
the destination file name.

3.2.2.2. Controls
The layout of docking panes and the control windows arrangement has to be modified directly in the applic-
ation. The right part of the window provides only the overview of the structure.

Tree View Levels

There are 5 levels in the tree view:

1. [Display] (primary, secondary, etc.)

2. [Docker] (top, bottom, left, right)

3. [Column] (controls can be placed in a docker side by side)

4. [Tab] (one column can take multiple controls “layered”)

5. [Controls] in each tab.
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3.2.2.3. Modifying Tool Bars

• Select the [Toolbars] item within the list of layouts. The right-side part of the window changes.

• Choose one of the tool bars which you would like to modify from the [Toolbar] pull-down menu.

• If selected, de-select the [Use Default] option on the right.

• Any button of the tool bar may be hidden by de-selecting it. No buttons can be added to any of the tool
bars except the [Main Left Tool Bar].

• The whole tool bar can be hidden by de-selecting the [Show Toolbar] check box.

• There are two sizes of buttons available. Select the [Large Buttons] option to use the larger one. This
setting is shared by all tool bars.
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Modifying the Main Left Tool Bar

Custom user buttons can be added to the main left tool bar. You can define your own buttons which run
single macro functions or execute macros . Select the [Main Left Toolbar] from the pull-down menu.

Lets say that we very often use the [Image > Contrast] command. It is useful to add a shortcut button to
the tool bar. Press the [Add] button, and choose [Command] from the pull-down menu:

• A new command - [Command0] - is added to the list.

• Now, attach the NIS-Elements AR command: Open the pull-downmenu on the right side of the [Command]
edit box and click [Command List].

• A list of commands appears. Choose [_Contrast()].

• Confirm the selection by [OK].

It is possible to create a sequence of commands, by repeating this procedure.

If you are not satisfied with the default icon, you can change it by pressing the [Change] button. A window
for selecting the icon appears. You can select the image from the NIS-Elements AR icon set by default, or
load some other from any file containing icons (ico, dll). You can define the icon for the command in a disabled
state, too.

It is handy to define a tool-tip (a text that appears when the mouse cursor is placed over the icon) for your
command. Simply write the text into the [Tooltip] box. You can change the position of the command in the
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tool bar using the arrow buttons. The [Default] button discards your changes and inserts the default set of
commands to the tool bar.

3.2.2.4. Modifying the Menu
The [Main Menu] and some of the [Context Menus] accessible by right-click within the application window
may be modified. Items of the context menus can be hidden by de-selecting them similarly to the tool bars.
The main menu can be modified as follows:

Modifying the Main Menu

• Select the [Main Menu] in the topmost pull-down menu.

• Any item may be added to the main menu - a [Separator], a [Menu Command], a sub-menu ([Menu
Popup]), and even a new menu ([Main Menu Popup]) - by the [Add] button.

• Select the existing menu item under which you would like to place the new item.

• Click the [Add] button and select the item to be added from the pull-down menu.

• Edit the [Item Properties] .
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Note

The [Default] button discards all changes and loads the main menu original configuration. The
[Remove] button deletes the selected item. The arrow buttons move the selected item up/down.
The [Use Default] check box, when selected, applies the default settings to the menu.

Item Properties

Text
This is the text which appears in the pull-down menu. You may add “&” before any letter - such letter
will be considered a keyboard shortcut when browsing the menu.

Hot key
One or more hot key shortcuts may be assigned to the command. Just press the [Add] button and press
the key combination. Press [Remove] to remove the selected hot key.

Enabled/Disabled bitmap, Command
These fields serve for assigning a bitmap image and a macro function to the menu command. It works
the same way as when modifying the Main Left Tool Bar (described above).

3.2.2.5. Commands
These settings enable to run a command or a macro right before and after you switch to the layout.

3.2.3. Docking Panes
Docking panes are square spaces inside the application window, where you can place (dock) any of the
control windows. There is one docking pane available on each side (Right, Bottom, Left).

To Display a Docking Pane

• Go to the [View > Docking Panes] sub-menu and select the pane you would like to display.

Note

The [Docking Panes] sub-menu can be also displayed by right-clicking into the empty application
screen.

• The docking pane appears, either empty or with some window(s) docked inside.
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• Repeat this procedure to display more docking panes.

Handling Control Windows

Various control windows can be displayed docked within the docking panes or they can be floating. See the
following picture:

The Docked Control Window Caption

To handle the control windows (CWs), you can:

Add CW to a docking pane
Right click inside a docking pane (3) and select the control window to be displayed from the context
menu. If the window is already opened somewhere else (in another docking pane or floating), it closes
and moves to the new destination.

Close CW
Click the [cross] button (2) in the right top corner of the tab.

Drag CW
Drag any CW by the tab and drop it somewhere. If you drop it by the edge of a docking pane, it will create
another column of this pane. If you drop it over the caption of another CW, it will be docked in the same
pane as a new tab. If dropped somewhere else, the CW will be floating.

Note

A color frame appears when you place the mouse cursor dragging a CW over the edge of a
docking pane or a caption of another CW. It indicates that if you drop it, its placement will be
handled automatically.

Minimize the docking pane
Click the arrows in the top left corner. The pane minimizes to a stripe by the edge of the screen. It can
be restored to its original position by double clicking this stripe or by clicking the arrows again.

Close the docking pane
Click the [cross] button (4) in the docking pane caption. Or you can right click the pane and unselect
the [Docking View] option.

Dock/undock CW
To dock (and undock) a CW, double click its tab.

Display CW
Another way to display a CW is to go to the [View] menu and select the desired control window. The
controls are sorted to several groups:

Acquisition
Analysis
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Visualization
Macro
After that, the CW appears floating on the screen.

Shrink/Expand dockers
Havingmore docking panes opened, a situation where there is not enough room for the control windows
can occur. In such case, the [Shrink] and [Expand] commands shall be used.

• Right click the pane you would like to shrink/expand. A context menu appears.

• Select the [Expand]/[Shrink] command. When one of the panes shrinks, the neighbouring pane
expands to the emptied corner and vice-versa.

26

NIS-Elements AR



3.2.4. Appearance Options
General appearance adjustments can bemade in the [Options]window. Run the [Edit > Options] command
and switch to the [Appearance] tab.

The following properties can be adjusted here:

• Application Background

• Color Scheme Selection

• Application Language

• Document Tool Bars Visibility and Style

• Channel Tabs Visibility

• Layout Tabs Visibility

• Initial Zoom of Images

• etc.
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3.3. Organizer
Apart from the main application layout used for capturing and image analysis, NIS-Elements AR provides an
extra layout called [Organizer]. Organizermakes the work with image files and databases as easy as possible.

To activate it, click the button located in the top right corner of the application window or press
[F10].

The screen is by default divided into two identical panes, each pane switchable between two modes: the
[Files View] and the [Database View].

• [Files] - This button switches the pane to show a directory tree and images from the selected folder
(and optionally its sub-folders).

• [Database] (-DB- option) - This button switches the pane to show the database structure and lists
images from the currently selected database table.

To switch from one pane to the other, use the [View > Next Pane (F6)] command. To copy files between
the panes, simply drag the images from one side to the other side.

Features Available in the Files View

The Files View

• This button toggles the display of the directory tree. You can switch it off to get additional space to
display images.

• In this pull-down menu, it is possible to set the file type and only the one will be
displayed. Or, [All Images] can be displayed.
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• If this check-box is selected all images from included sub-folders are displayed.

Features Available in the Database View (-DB- option)

The Database View

• This button displays the detailed information about the selected image. You can switch it off to get
additional space to display images.

• This pull-down menu displays the database connection name and enables to switch
between active connections.

• This pull-down menu selects a database table to be displayed.

3.3.1. Image Filter
Both views, [Files] and [Database], have the option to define a filter. It enables you to display only images
which fit the defined conditions. One or two conditions may be applied.

• Pressing this button invokes the filter setup window.

• This button activates the filter.

Basic Mode

This mode enables you to filter files according to one condition.
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Advanced Mode

This mode enables you to define two conditions with a relationship between them. Either select [OR] to
display files matching at least one condition, or select [AND] to display files which match both conditions.

1. [Search in field] - select the field where NIS-Elements AR should search for a given expression.

Note

When using a filter in the [Files] view, the fields from file-properties are listed in the menu. In
the [Database] view, the list shows names of fields from the current database table.

2. If the selected field is of a numerical type (e.g. Size, Calibration, File date etc.) you can specify, whether
you want to find the exact [value] or a value in a given [range]. This is selected by the [Condition type]
radio button.

3. If the field type is [Text] , the [Occurrence] setting determines the way of evaluating the expression:

• [Anywhere] - If the given sequence of characters is found anywhere in the field, the systemwill evaluate
it as a match. For example: you have entered “set” to the [Values] field. The filter will select records
with the following field values: “set”, “reset”, “settings”, “preset”, etc.

• [Exact] - If the given sequence of characters exactly equals to the content of the field, it is evaluated
as a match. Fields containing the “set” value only will match.

• [Start] - If the entered string is found at the beginning of a field, it passes the condition. For example:
fields containing “set”, “settings”, “setup” will match.

• [All letter strings] - It is possible to search for more expressions. These should be entered separated
by commas. If you want to enter an expression with a space, insert it quoted. If this option is selected,
only records where all of those expressions appear (anywhere) will match.

• [Any letter string] - This option is for entering multiple expressions as above, but this time every field
with an occurrence of at least one from the given expressions is matched.
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3.3.2. Operations with Images

• To open an image from the [Files] view, double click its thumbnail. NIS-Elements AR will close [Organizer]
and display it in the main window.

• To select multiple images, either click on the first and the last image holding the [Shift] key (continuous
group selection) or click individual images with the [Ctrl] key down.

• You can copy one or more images from one folder to another by “drag and drop”. This quick method can
be used for inserting images to a database too. Simply drag the image from a folder and drop it onto the
pane, where the database table is opened.

• To delete selected images press the [Delete] key.

All those operations and some other can be invoked also from the context menu, which appears each time
you right click on the image thumbnail:

Thumbnail Displaying Options

You can adjust the way images are shown in the organizer.

Thumbnail View
Press this button and select the size of displayed image thumbnails. Selecting the [Detailswith preview]
option will display images below each other with all available information aside.

Rotating Images
There is a possibility to rotate images fromwithin the organizer. It affects not only the image thumbnails,
but the image data too. Press the corresponding buttons.

Autocontrast
Press this button to turn the [Apply autocontrast to thumbnails] option ON. It enhances the image
thumbnails automatically. Dark images gain details.
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3.3.3. Sorting of Images
To order displayed images, right click anywhere in the pane - a context menu will appear. Move to the [Sort
by] sub-menu which offers several ordering criteria. If the ordering is turned ON already, the icon is displayed
on the left side of the applied criterion.

3.3.4. Grouping of Images
To arrange the view of images efficiently, you can use the capability of grouping of images. Drag the column
name bar to the grouping bar (right above the column name bars). All files with matching field values of the
selected column will be grouped together. This can be undone by dragging the column caption back to the
others. See [fig. The Files View] (the Dimensions column is grouped).

3.3.5. Adjusting the Organizer Layout
The pane size is adjustable. To resize it:

1. Place the mouse cursor over the dividing line in the middle.

2. The cursor becomes an arrow with two tips.

3. Drag it left or right to the new position.

Also, the following buttons appear in the top bar:

• Resizes the panes to achieve the same size for both of them.

• Resizes the pane to its maximal/minimal size (one pane is then displayed on the whole screen).
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4. Setting the Hardware Up

4.1. Working with Cameras
This chapter is dedicated to users running the active version of NIS-Elements AR - equipped with a camera.
Let's assume the camera works properly, is connected to the PC with proper system drivers installed and
running (if required by the camera).
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Setting Up the Camera

1)
Selecting the Driver

You will be asked to select the camera driver every time you launch NIS-Elements AR. You can change
the driver later using the [Acquire > Select Driver] command. Choose the driver that matches your
camera:

Multiple Cameras

In some cases, two cameras can be connected to one system. If so, check the [EnableMulti Camera]
option and select the [Second driver] from the list.

The following set of buttons appears in the top tool bar when multiple cameras are used:

2)
Selecting a Camera
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Color cameras can be used in a monochromatic mode. The actual camera type (color/mono) can be
selected by the [Acquire > Select Camera] command.

3)
Adjust the Camera Settings

Exposure time, camera resolution, and other camera-specific features are adjustable from the
[Camera Settings] window. To invoke it, use the [Acquire > Camera Settings] command.

4.1.1. Live Signal from Camera

Live Formats

A camera format is a set of attributes of a video signal such as: resolution, bit depth, frame rate etc. The live
signal is a stream of image data, coming from the camera to your computer in real time. NIS-Elements AR
provides two different camera modes: [Fast] and [Quality], each serving a different purpose. The format of
both modes can be set within the [Camera Settings] control window.

Live - Fast
This tool bar button runs the [Fast] live mode. This mode is usually set to low resolution, therefore the
frame rate is high. It is used for searching the specimen or when focusing manually.

Capture - Quality
This tool bar button runs the [Quality] live mode. This mode should be set to high resolution which re-
duces the camera frame rate. It is applied every time the [Capture] button is pressed.

4.1.2. Capturing Images
Although it is possible to perform some procedures directly on the live image, other image operations require
[captured] or [frozen] images. If you try to perform such procedure when the live image is active, NIS-Ele-
ments AR automatically freezes the image. Let's see the difference between the [Capture] and [Freeze]
commands:

Capture
When pressed, the camera exposure runs till the end of the current frame, and the next frame is captured
and displayed on the screen (it is the first frame with the complete exposure after you have pressed
the [Capture] button).

Freeze
The [Freeze] button interrupts the camera exposure, and displays the very last complete frame.

Note

If you are using the [Fast] mode and press [Capture], NIS-Elements AR will automatically switch
to the quality mode to capture the image. When the image is captured, it is opened on the screen
as a new document.
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4.2. Optical Configurations
Typically, laboratory computer image analysis systems consist of a computer, a camera, and a microscope
equipped with certain accessories (objectives, filters, shutters, light, rotary changers, etc). Most of the
mentioned microscopic hardware is often motorized and therefore can be controlled by NIS-Elements AR.
In addition, it is possible to integrate single settings of all these devices into one compact set called [Optical
Configuration]. It is recommended to create several optical configurations containing particular devices
settings. Then a single click can completely change the current hardware configuration.

Creating New Optical Configuration

1) Please check that all the devices (microscopes, cameras, etc.) that you want to associate with the
new optical configuration are properly attached to the system and working.

2) Choose the [Calibration >NewOptical Configuration] command. The following window appears:Ad-
just the settings of the devices to match the intended state which will be saved to the optical config-
uration.

3) Type the name of the new optical configuration to the [Name] field. We recommend to use a short
descriptive name, the name will be displayed in the main tool bar.
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4) In the left column, select which device settings to associate with the Optical configuration.

Camera setting
A list of the current camera properties appears on the right. It is being updated dynamically.

Channel setup
These settings determine how channels of newly captured images will be named and what color
will be assigned to them. The available properties depends on the current camera setup (col-
or/mono, triggered acquisition engaged or not, dual view engaged or not, etc.). In the mono
camera mode, you can either assign the name, the emission length and color to the channel
[Manually], or leave this task to NIS-Elements AR (the [Automatically] option). In such case,
information of the light path (emission wavelength) will be used to determine the channel name
and color.

Microscope setting
Select which parts of the microscope shall be included in the configuration by checking them in
the [Used devices] dialog box. If there is more than one shutter available and you would like
to associate a shutter with the optical configuration, select which one is the [Active Shutter]
from the pull-down menu.

Objective
An objective mounted to a motorized nosepiece can be included in the configuration. Select the
objective from the pull-down menu. Objectives which are currently assigned to any position of
the nosepiece are listed. See [Objectives].

Note

The objective must be assigned to a nosepiece position via the microscope control
pad or the nosepiece control window first.

5) If some of the device settings still need to be adjusted, click the [Camera & Devices Controls]
button and select the appropriate control window from the pull-down menu. Adjust the settings
within the control window, the optical configuration will be updated automatically.

6) Click [Finish] to save the new optical configuration and to close the window.
7) You can create more optical configurations by repeating the procedure. The optical configurations

are saved to registry immediately and can be exported to an XML file ([Calibration > Optical Con-
figurations > Backup]).

Managing Optical Configurations

To display the optical configurations manager window, run the [Calibration > Optical Configurations]
command. You can make the following actions from the window:

• Create, duplicate, rename, delete, copy settings and switch between optical configurations.

• Modify optical configuration properties.

• Import and export optical configurations to/from an XML file.
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Operations with Optical Configurations

Once created, the configuration appears in the list and can be shared with other users by changing the
[Private] option to [Shared] (see [User Management]). The following operations can be performed on the
selected configuration:

• It can be deleted by pressing the [Remove] button. A confirmation dialog box appears.

• Its name can be changed by the [Rename] button. A button with the configuration name appears in the
tool bar (if the [Show on toolbar] option is selected).

• The configuration settings may be transferred to another optical configuration by the [Copy to] button.
Press the button and select the optical configuration to be overwritten with the current one.

• A copy of the configuration can be made via the [Duplicate] button.

• The configuration can be applied by the [Set As Active] button.

• The settings of all optical configurations can be exported to an external XML file using the [Backup] button.

• The previously exported optical configurations settings can be loaded from the XML file via the [Restore]
button.

• The list of optical configurations can be ordered manually via the arrow buttons.

• Each configuration can be arbitrary modified within the right-side portion of the window.
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4.3. Objectives
If you want to performmeasurements on captured images it is wise to calibrate the objectives used to capture
the images. Whenever an image is captured through a calibrated objective, the image inherits its calibration.

4.3.1. Managing Objectives
Run the [Calibration > Objectives] command. The [Objectives] window appears:

A list of used objectives can be created within the Objectives window. For each objective, the objective name,
position in the changer, storage status and the calibration are displayed. A [Calculator] icon next to the
calibration value indicates that the calibration has been calculated from objective properties. If the calculator
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icon is missing, it that means the calibration has been performed manually. Use the buttons on the right
side to manage the objectives:

Insert
Click the button and select one of the predefined objectives from the list ordered by magnification.

New
Press this button to create a custom objective. The new objective will be added to the list. Then, define
the [Main properties] and the [Physical properties] of the objective.

Duplicate
If zoom is used, the objective calibration must be re-calculated accordingly. Use this button to make a
copy of the objective and define the zoom factor in the window which opens.

Remove
This button deletes the selected objective.

Recalibrate
Starts the calibration of the selected objective. See [Objective Calibration].

Backup
Enables you to export the complete list of objectives to an XML file. The standard [Save As] window
appears.

Restore
This button enables you to import a complete list of objectives from an external XML file previously
created by the [Backup] button.

Current Unit
This button invokes a pull-down menu where units for the whole application can be selected.

Edit the properties of the selected objective in the bottom part of the window. Press the [Close] button to
finish this window.
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4.3.2. Objective Calibration
After you press the [Recalibrate] button in the [Objectives]window or when creating a new custom objective,
the following window appears:

Select one of the calibration methods:

• The [Manual] calibration lets you draw a distance into a picture and assign real length to it (see below).

• If a motorized XY stage is available, the [Auto] and [4 points] automatic methods appear.

Press [OK] to continue...
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Manual Calibration

1) When performing a manual calibration, the live image starts automatically and the following window
appears:

2) Select one of the icons to draw a distance to the image. If you know the precise calibration value
(px/unit), press the [Pixel Size] button to enter the real size of one pixel:

Enter the calibration value, select units, and confirm the calibration by [OK]. If you do not know the
pixel size, you will have to continue with the calibration on live image:

3) Insert a calibration slide to the microscope stage.
4) The distance is defined by placing lines (Horizontal, Vertical, Parallel) to the image. Choose the orient-

ation of the lines by pressing the appropriate button.

Note

If you are sure the camera angle is 0, 90, 180, or 270º, it is recommended to select either
vertical or horizontal lines. Otherwise, select the parallel lines.

5) Click into the image to place the first line. Place the second line in the intended position by another
click.

Note

You can modify the line position while holding the mouse button. After you release the
button no further changes can be made. When “Parallel lines” were selected, draw the first
line by clicking twice inside the image. The line can be moved and adjusted arbitrary by
mouse. When satisfied, finish the first line by right-click. The second line can be placed by
another click to the image, this time only to adjust the distance from the first line. The
process is completed by right-click.
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6) The following dialog box appears:

7) Enter the distance between the two lines and select correct units.
8) Press [OK]. The objective is calibrated now.

Automatic Calibration

The [Auto method] is fully automatic. NIS-Elements AR moves the motorized stage, acquires two images,
and calculates the calibration from the shift of the images. If you select the [4 points method], the system
draws four points on the screen (subsequently) and asks user to move one significant part of the specimen
to each position. After all four steps are completed, the calibration is calculated from the moves of the stage.

4.3.3. Units
NIS-Elements AR supports the following units:

• pixels

• nanometers

• micrometers

• millimeters

• centimeters

• decimeters

• meters

• kilometers

• inches

• mils

If the image is uncalibrated, pixels are the only units available. In case of a calibrated image, it is possible
to select other units which are then used to display all values (e.g. measured length/area). There are two
ways of how to select the desired units:
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• Right click the document status bar where the calibration is displayed. Select the units and precision from
the context menu.

• Or, click the [Current unit] button located in the [Calibration > Optical Configurations] command
window and select the units.
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4.4. User Management
NIS-Elements AR user rights management utilizes MS Windows user accounts. Different user rights to some
NIS-Elements AR features can be assigned to three user groups:

• Admin

• Common

• Guest

Run the [Edit >Options] command and select [UserRights] in the left column, the following window appears:

Lets explain the user rights on the example of layouts: Layout settings can be stored in two places (storages):
private or shared. When you create a new layout, it is set as [private] automatically and saved to your windows
account profile. Nobody else can ever use or change the private layout. However, you can decide to share
the layout with other users and set it [shared] (within the layout manager). All users can utilize the shared
items, but only members of a group with the permission to modify them can do so.
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User Rights Options

Current user
Displays the current MS Windows user.

Log As
Opens the [Login As] dialog which enables you to login as a different user with stronger user rights for
the purpose of changing User rights settings.

Enumerate All Windows Users
This button starts copying MS Windows accounts to NIS-Elements AR. The accounts are assigned to
user groups (admin, common, guest) according to their Windows permission settings.

User Rights for Group
From this pull-down menu, select the group you would like to modify permissions of. You have to have
the [Modify users] permission to do that.

Modify user rights
Users can modify permissions of all groups in this window, and apply the [Set active camera as
shared] option.

Modify shared objectives
This option enables user to delete, recalibrate, etc. objectives within the [Calibration > Optical
Configurations] window.

Modify shared optical configurations
This option enables user to modify existing optical configurations in the [Calibration > Optical
Configurations] window.

Modify shared layouts
This option enables user to modify shared layouts in [View > Layout > Layout Manager] window.

Modify shared macros
This option enables user to manage shared macros via the [Macro > Manage Shared Macros]
command.

Modify shared reports
This option enables user to manage shared reports via the [File > Manage Shared Reports]
command.

Select camera
Users with this permission can select any camera driver from the [Acquire > Select Driver]window.
Otherwise they are forced to use the current shared camera (below).

Modify devices
Users with this permission can add/remove/modify deviceswithin the [Devices>ManageDevices]
window.

Current shared camera
This field informs you which of the available cameras is set as [Shared]. Users without the [Select
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camera] permission will only be able to use this camera.

Set active camera as shared
This button sets the currently selected camera as default for all users without the [Select camera]
permission.

Export/Import user rights
These buttons enable anyone to save/load complete settings of users and user groups to/from an ex-
ternal XML file. Standard [Open] and [Save As] windows appear. Having the data exported may be
useful when copying the settings to other computers.

Defaults for this Page
Pressing this button restores the default settings of this window. All your changes will be lost.

Log As

NIS-Elements AR user rights management primarily utilizes MS Windows user accounts to recognize the
users. However, for the purposes of NIS-Elements AR user rights administration, you can log in temporarily
under a different (MS Windows) account. Press the [Log As] button in the [Users] tab in the [Options]
window. A dialog box appears:

Select the user name you want to log-in as. Enter a valid password and press [OK]. The new user identity is
available only while the User manager is opened, it does not have any effect to other NIS-Elements AR
functionality or other applications.
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5. Capturing
Having NIS-Elements AR installed and all hardware accessories set up, you can start capturing images. The
easiest way is to capture single images one by one. There are also other ways of acquiring image documents,
some of them specialized and needing some specific hardware. They are described in the subsequent
chapters.

5.1. Single Image Capture

• Turn the connected camera and other devices ON and start NIS-Elements AR.

• When the application is started display the [Camera Settings] control window ([Acquire > Camera
Settings]).

• Switch camera to the [Live-Fast] mode and adjust the camera settings to get the live image clear.

• Focus the objective on the scene you would like to capture the image of.

• Switch to the [Live - Quality]mode and adjust its settings, especially the [Exposure time] and [Format]
. These settings will be used every time on image capture.

• Switch back to the [Live - Fast]mode. This is the usual mode for smooth work because less of the hardware
resources are engaged.

• Capture the image by pressing the capture button on the horizontal toolbar, by invoking the [Acquire
> Capture] command.

• A new image is opened and named “Captured” automatically.
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5.2. ND2 Acquisition
NIS-Elements AR being a multi-purpose imaging system can be used as a handy tool to study objects, live
organisms, processes, etc. The universal [ND2](N-dimensional) file format is what makes this possible. One
[ND2] file can containmultiple images organized according to what type of acquisition they came from. There
are the following acquisition types:

Note

Each acquisition type gives a name to the corresponding dimension of the resulting ND2 file. For
example, we can speak about two-dimensional TZ ND2 file, which means the file contains the
Time-lapse dimension and the Z-series dimension.

Time-lapse - T
A sequence of images can be captured over a period of time and create a time-lapse document.

Multi-point - XY
Images from different areas of the slide can be acquired.

Z-series - Z
Several techniques utilize Z-stacks of images. Such Z-stack can be for example converted to a 3D
model of the specimen.

Multi-channel - λ
Fluorescence signals can be captured selectively using excitation an emission filters, each of them
creating a different color channel.

Large image - M (-6D- option)
When the area of interest exceeds the camera field of view, you can capture a large image composed
of multiple image frames and let it be stitched by an automatic algorithm.

An ND2 document can be created (captured) either containing one dimension or combining several of them.

• Single-dimensional documents can be created automatically (using motorized accessories) or manually
using commands from the [Acquire] menu.

• To create a multi-dimensional document, use the [Applications > ND > Define/Run Experiment (ND)
(-6D- option) ] command (ND module required).

Special Options

Special options can be applied to ND experiments:

Auto Focus
Automatic focusing can be used during the experiment. You can select the auto-focus method that best
meets your needs. It can be determined whether the focusing shall be performed at the beginning of
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the whole experiment or at the beginning of each phase. The [Define] button shows a window where
you can define parameters of the selected focusing method.

Closing Shutter
The active shutter can be closed between single image acquisitions. Just select the [Close active
Shutter...] option in the experiment window.

Running Macro Commands
You can define a command (or a macro) to be run in various stages of the experiment. Select the timing
in the [Advanced] section of the experiment window and enter the command to be run.

In/Out signals (-LO- option) (-6D- option)
An ND2 experiment can control some accessory devices but can be controlled by another accessory
devices at the same time by sending/receiving Analog/TTL signals. This feature requires additional
hardware (NI DAQ controller set). If the NI DAQ PCI card is installed, an extra tab called [Inputs/Outputs]
appears within the ND experiment window. See [Applications > ND > Define/Run Experiment (ND)
(-6D- option) ].

5.2.1. Time-lapse Acquisition
Detailed studying of long-lasting processes is enabled by the time lapse acquisition mode of NIS-Elements
AR. The achievable experiment duration is limited by the hardware abilities of your PC only. Invoke the [Acquire
> Capture Timelapse > Capture Automatically] command to set the experiment up:

The [Time schedule] table enables you to define consecutive time phases where duration, interval between
single images, and number of images of the phase can be adjusted. The [Interval], [Duration], and [Loops]
settings are bound together, so you just need to set two of these parameters. The remaining parameter is
calculated automatically. Only the selected time phases will be captured.

The flag mark indicates the Duration/Loops priority. For example: if the camera exposure time exceeds the
defined [Interval] between frames, than the experiment settings are not achievable - only themarked column
will be pushed to be correct. You can set the priority column by clicking on its caption.

5.2.2. Multi-point Acquisition
Automatic multi-point acquisition is available when a motorized XY(Z) stage is connected to the system. An
arbitrary array of XY(Z) positions can be defined to be scanned during a multipoint capture experiment. The
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Z position can be included optionally. The defined array can be saved (and loaded later) to an XML file. Run
the [Acquire > Capture Multipoint > Capture Automatically] command.

To Define a Multipoint Array:

• Move the stage to the first position.

• Press the [Add New] button. A new line containing current coordinates of the stage appears in the
list.

• Move to the next position and repeat the steps until you have all the intended points defined.

To Change a Single Z Coordinate:

• Make sure the [Move stage to selected point] (-LO- option) is pressed. This button ensures that
the motorized stage moves to the coordinates of the currently selected point.

• Click inside the line you would like to change.

• Move the Z drive to the new position.

• Click the [<-] button.

Note

The XY coordinates of one point cannot be adjusted (unless you delete it and add a new point).

Offset All

The offset all button can shift the XY coordinates of all points in the same way:

• Make sure the [Move stage to selected point] (-LO- option) is pressed. This button ensures that
the motorized stage moves to the coordinates of the currently selected point.
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• Select one point of the list.

• Move the XY(Z) stage to a new position (define the offset).

• Press the [Offset All] button.

• The coordinates of all points change - the same shift which you made with the stage is applied to them.

Special Options

Relative XY
Check the [Relative XY] item to consider all coordinates as relative with respect to the current stage
position. Any of the points may be used as the reference point, just right-click it and select [Set this
point as a reference position].

Optimize
If the [Optimize] button is pressed, the system will re-order the defined points in order to minimize the
XY stage trajectory.

Custom
A grid of points aimed to be used for scanning well-plates can be defined using the [Custom] button.

Redefine reference Z after Auto Focus/PFS
Check this option to redefine reference Z position after performing autofocus or PFS (if AF or PFS is
turned on).

Split Multipoints (-LO- option)
Select this box to perform the [File > ND > Split Multipoints] command directly after the ND2 experi-
ment.
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5.2.3. Z-series Acquisition
Automatic capturing of images fromdifferent focal planes of the specimen can be performed. Run the [Acquire
> Capture Z-Series > Capture Automatically] command. There are three different approaches of how to
set the experiment:

There are the following ways of defining the Z drive range:

Range by Top/Bottom Position and Step

1) Press the button, the cube turns blue.
2) Run the Live camera signal. In case you have two Z drives, select the [Z device] from the pull-down

menu.
3) Set the Z range: move the Z drive to the top position and press the [Top] button, move it to the bottom

position and press the [Bottom] button.
4) Define the [Step] size in µm or the number of steps to be captured.

Note

In this mode the [Home position] is assigned to themiddle one of all the defined steps automatically
(e.g. for 5 steps, it is the third step, etc.). The [Reset] button discards the Top, Home, and Bottom
positions settings.

Range by Home Position and Range

1) Press one of the following buttons, the cube turns yellow. The range is defined by the home-position
and the scanning range:

• [Symmetric mode] - Define the [Range] by inserting a value in µm.

• [Asymmetric mode] - The range is specified by two values, [Below] - the distance below
the home position, and [Above] - the distance above the home position.

2) Run the Live camera signal. In case you have two Z drives, select the [Z device] from the pull-down
menu.
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3) Move the Z drive to the position which you would like the Z drive to move around. Press the [Home]
button to define the home position.

4) Specify the scanning [Range] .
5) Define the [Step] size in µm or the number of [steps] to be captured.

Defining TIRF position

When the TIRF system is enabled, the TIRF option appears in the right portion of the window. To set the TIRF
position:

• Click the [Define] button. A window appears waiting for you to move the Z drive.

• Move the Z drive to the correct TIRF Z position.

• Click [OK]. The TIRF position value appears in the field above the [Define] button.

Using TIRF

To enable TIRF:

• Select the [TIRF] check box within the Z-Series experiment settings

• At least one value of the [Z phase] column of the Multi-channel acquisition setup has to be set to [TIRF].
(See [Multi-channel Acquisition].)

5.2.4. Multi-channel Acquisition
Fluorescence (multi-channel) pictures can be acquired. Run the [Applications > ND > Define/Run Exper-
iment (ND) (-6D- option) ] command and select the [Lambda] tab. There you can set the multi-channel
experiment.

Channels Setup

Specify how many channels are to be captured. Set a descriptive name of each channel and select the op-
tical configuration that is to be used for its acquisition. If no suitable configuration exists, you can create a
new one by selecting the [<define new>] option from the pull-down menu in the Optical Configuration
column. The [Comp. Color] column specifies the color tone, in which the channel will be displayed.

55

User's Guide



Special Options

Camera
When you are in a multi camera mode, you can select the camera to capture each channel.

T phase
If there are T dimensions engaged in the experiment, another column called T Phase appears in the
table. You can reduce the number of captured channels by selecting [First] or [n-th] (the channel is
included in the first or every n-th time phase only).

Z Phase
If there is a Z dimension engaged in the experiment, another column called [Z Phase] appears in the
table. You can reduce the number of captured channels by selecting the [Home] option - the channel
will be captured within the home position of each Z series only. Also, if a [TIRF] system is available, the
[TIRF] option appears as an option. If selected, the channel will be captured within the TIRF position of
each Z series only (the TIRF position can be set within the Z-Series acquisition setup window).

Note

The phase settings (T and Z) can be combined in any way, but at least one channel must be
included in every T or Z loop whichmeans that the [All] optionmust be selected in both columns
for at least one channel.

Merge Cameras
Available only in multi camera mode. When using two cameras, two ND documents will be created by
default. If it the [Merge Cameras] option is selected, only one ND document is created. This ND docu-
ment contains the maximum parameters from the two cameras (width, height and bit depth per com-
ponent).

Stretch Camera images to Same Size
Available only for multi camera mode. When the two cameras differ in resolution, the camera images
will be stretched to the same size.

Manual Filter Change

The [Wait for user before changing to next channel] advanced option enables you to switch the
wavelength filters manually during themultichannel experiment. Use this option if there is no automatic filter
changer available.

5.2.5. Combining N Dimensions
The dimensions can be combined together creating an N-dimensional document as the result:

• Run the [Applications > ND > Define/Run Experiment (ND) (-6D- option) ] command.
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• The following control window appears:

• Select one or more dimensions (tabs) which should be included in the resulting ND2 file. Above the tabs,
there is a preview of how the nd2 file structure will look like.

• Press the [Order of Experiment] button and select the item which defines the desired order of loops in
the ND document.

• Set the parameters of each dimension acquisition.

• Select whether to save the ND document directly to a file or just to keep it inmemory to be saved afterwards.
To do so, select the [Save to File] check-box. The path and the file name shall be defined if saving to a
file is preferred.

Note

When saving to a file, the size of the resulting ND file is not limited by the amount of RAM installed
to your PC, but by the amount of free space on your hard-drive.

• Click the [Run now] button to start the acquisition.

Save to File

An image can be captured and savedmanually after the experiment is finished, or it can be saved to harddisk
“on the fly”:

• Check the [Save to File] box. The window reveals an extra section.

• Insert the [Path] or use the [Browse] button to define the destination folder.

• Specify the [Filename].
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Recorded Data

The nd2 file contains various [Recorded Data] which carry e.g. acquisition times of single frames. Some
of them can be recorded optionally:

• Press the [Record Data] button. The following window appears:

• Select whether to record the data for each frame ([Per Frame]) or with a certain [Frequency].

• The data to be recorded shall be check-marked.

• To view the recorded data of an opened ND2 file, invoke the [File > Image Properties] command and
switch to the [Recorded Data] tab.
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ND Experiment Progress

The following window appears while the experiment is running:

The window displays the experiment overall progress, time elapsed from start of the experiment, estimated
remaining time, remaining free space on the disk where the captured ND document is being saved, and
detailed messages about the experiment work-flow such as: “waiting for next loop”, “stage moving” etc.
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You can control the running experiment by the following buttons:

Next Loop
When the time interval of one time loop is long enough, the system captures all the included dimensions
and waits for the scheduled beginning of the next loop. In such case the [Next Loop] button becomes
enabled and you can click it to start the next time loop ahead of the schedule.

Next Phase
After you press this button, the experiment jumps to the beginning of the next time [Phase] after the
current loop is finished.

Start Phase
Use this button to start the time phase selected in the combo box. Select the phase first and press the
[Start Phase] button.

Pause/Continue
The experiment can be paused by the [Pause] button. Let it go on by pressing the same button.

Refocus
If there is a need to focus manually, press the [Refocus] button. It pauses the ND experiment and runs
[Live] camera signal.

Finish
This button stops the experiment and saves captured data.

Abort
Use this button to stop the experiment without saving the captured data.

Events
If a remarkable event occurs during the experiment, the user can press a shortcut key and the inform-
ation will be saved to the resulting ND2 document. You can define the key-shortcuts after you press the
[Events] button. See [ND2 Documents].
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5.3. Capturing to Ring Buffer
The Capturing-to-RAM technique enables user to record sequences displaying very quick actions - lasting
tens of milliseconds. Make sure that the RAM Capturing buttons are displayed on the [Grabber & Devices
ToolBar] (see [Modifying Layout]), or use the corresponding commands in the [Acquire > RAM Capture]
menu.

Set the Ring Buffer Size

The technique uses a ring buffer to store temporary data. The ring buffer is a part of virtual memory that is
being constantly (and repeatedly) filled with the live image data. Depending on how fast the action to be
captured is, you should set the ring buffer size (in seconds).

• Click on the [Settings] button.

• Set the [Time buffered before/after] values. These represent the time before and after you click the

[RAM Capture] button. The whole time interval will be included in the sequence.

• Confirm it by [OK].

Turn the Buffer ON

• Click on the [Circular buffer ON] button to enable recording of Live image to RAM.

• The ring buffer functionality gets activated.

Capture the Image Sequence

• Press the [RAM Capture] button.

61

User's Guide



• A new document window containing the captured image sequence opens.

Note

When the Camera is switched to Live mode, the circular buffer (ring) button indicates the buffer
activity. If the [RAM Capture] button is pressed afterwards, the captured image sequence will
contain frames from the whole time interval before and after the button was pressed. If you press
the button while in the Frozen mode or without the time buffer turned ON, only the [Time buffered
after] portion of the sequence will be captured.

62

NIS-Elements AR



5.4. Capturing AVI movies
AVI acquisition is an easy way of recording actions in real time. It produces *.avi video files, which can be
played by any standard video player, so you do not need NIS-Elements AR to view the resulting video. Please
see [Creating Movies].
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6. Image Documents

6.1. NIS-Elements AR Documents

6.1.1. Image Layers
Each NIS-Elements AR document can consist of the following image layers:

Annotation layer
In this layer, vector objects are stored. The results of interactive and automaticmeasurements, text labels
and other annotations can be included.

Binary layer(s)
The binary layer is usually the result of thresholding. By thresholding, you distinguish objects of interest
from background. A picture of night sky can make a nice example - shining stars may be “thresholded”
and compose the binary layer. Then, by means of automatic measurement, you can e.g. count them.
More than one binary layer can be placed over one image.

Color layer
The color layer contains the image captured by a camera. It can handle images with the depth of up to
16 bits per color component. The size of this layer determines the maximal size of the other layers.

Note

When saving an image, only some file formats are capable of saving all the layers. The other
image formats will save the content of the color layer only. See [Image Formats].
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Working with the Annotation Layer

There are two types of vector objects which can be placed over the image: annotation objects and measure-
ment objects.

This button of the right document tool bar turns the visibility of annotation layer ON/OFF. Right-clicking
the button displays a context menu with the following options:

• [Clear All Objects] will delete annotation and measurement objects.

• [Clear Annotation Objects] will delete all annotation objects.

• [Clear Measurement Objects] will delete all measurement objects.

• [Select Annotation Objects] will select all objects that are not the measurement ones.

• [Select All Objects] and [Deselect] will select/deselect all annotation and measurement objects.

Working with the Binary Layer

There are the following buttons at the bottom of the right document tool bar.

This button displays the binary layer (only). It can be edited by hand using the binary editor (press [Tab])
. See [Binary Layer ].

The binary layer can be displayed together with the color layer using the overlay mode. Several binary
layers can be created for one color image. Manage them using the [View > Visualization Controls >
Binary Layers] control window.

This button switches to view the color image (only).

6.1.2. Document Types in NIS-Elements AR

RGB Documents

Images acquired by a color camera typically consist of three components that represent red, green and blue
channel intensities. You can display a single color channel using the tabs located in the bottom-left corner
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of the document window. Or, an arbitrary combination of them can be selected while holding the [Ctrl] key
down.

Multi-channel Documents

These documents usually arise from fluorescence microscopy. Instead of 3 color components (RGB), mul-
tichannel images can be composed of arbitrary number of user-definable color channels.

Note

If there is a document that contains more than 8 components, the tabs in the bottom left corner
of the document are replaced by the wavelength dimension, similarly to how other dimension loops
of ND2 documents are displayed.

ND2 (multi-dimensional) Documents

An ND2 document is usually a sequence of images. One [ND2] file can contain multiple images organized
according to what type of acquisition they came from. There are the following acquisition types, also called
dimensions available: Time-lapse, Multi-point, Z-series, Multi-channel, Large-image. The dimensions can be
combined together.

6.1.3. ND2 Documents

6.1.3.1. Control Bar
When an ND2 file is opened, its structure is pictured at the bottom of the document window. There is a time
line with all captured images indicated by gray markers. The blue-highlighted marker indicates the currently
observed image. Below the time line, loops of each dimension are indicated by rectangles. In case the multi-
channel dimension is included and the number of channels does not exceed 10, the channels are indicated
by the color tabs at the very bottom of the document window.
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Browse the ND document by clicking inside the time line. You can also display a single loop by selecting the
corresponding blue rectangle. There are some examples, how the ND2 document control bar can look like
in different cases:

A T/Z/multi-channel document with some loops selected.

A T/Z/multi-channel document containing 11 channels and the time line hidden

An HDR multi-exposure document

Playing Controls

Play Sequence
Plays all images of the dimension at selected speed. If a selection is applied, only the selected images
will be included in the playback.

Stop Playing
Stops playing the sequence at the last displayed frame.

Previous Position
Displays the previous frame of the dimension.

Next Position
Displays the next image of the dimension.

Decrease/Increase Playing Speed
Changes the playback speed by one step down/up

Real Time Playing Speed
Sets the playing speed to real-time (as the document was captured).
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Maximum Playing Speed for Every Frame
Sets the playing speed to maximum while the display of every frame is guaranteed (when the speed is
set tomaximumby the + button, some frames are usually omitted when playing the sequence depending
on your graphic card).

Home Position
Displays the frame of the Z dimension that was set as “home” during the acquisition.

Event and Selection Controls

Insert User Event
This button inserts an event marker to the current frame.

Move to Previous/Next User event
Click these arrows to browse through the frames where user events occur.

User Event Selection
This button selects frames of the ND2 file according to the [Event Playing Range] settings - right click
this button and pick the [Event PlayingRange] command from the context menu to view/modify them.
A simple window appears. Define the number of frames/seconds which will be selected around each
event.

Range Selection
Clicking this button selects a user defined range of frames. The selection is done by mouse. A range
can be selected by mouse while holding the [Shift] key down. Single frames can be added/removed
while holding the [Ctrl] key down. Right-click the navigation bar to invoke the context menu. A selection
can be adjusted, deleted, or the nd2 file can be cropped.

Note

ND2 files may contain extremely large number of frames so it may be helpful to omit some
of the frames from the selection. Right click the [Range Selection] button and a context menu
appears. It enables you to select every 2nd, 5th, 10th, 20th, 50th, 100th frame. The [Select
All Frames] option selects the whole range of frames as if you have selected the first and the
last time phase with the [Shift] key down, but preserves the [Select Every...] setting.

Disable Selection
Press this button to de-select all frames of the ND document.

Tips

• Right-click the selection to invoke a context menu. The selection can be adjusted, deleted, or the nd2 file
can be cropped.

• Detailed info about dimensions will be displayed after you click the leftmost button of the control bar (T>,
Z>, ...).

• Place the cursor over one of the dimensions. A tool-tip which displays statistics of the dimension appears.
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Playing options

Right click the speed bar to display the following context menu and select the playing mode.

6.1.3.2. Events
User events can be pinned to any of the frames of the document in order to highlight a remarkable scene.
There are number of event types. Some of them are inserted automatically while the ND experiment is running,

others must be defined by user (by the button).

Once there is one or more events within the time line, you can manage them via a context menu. Right click
the event marker, a menu appears with the following options:

• Remove All Events

• Event Playing Range

• Event Manager

• Remove Event

• Edit Event
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When you open the [EventManager], all events within the ND documentmay be edited through the following
window. The time can be put in, and the event type selected from a combo box.

6.1.3.3. Views
There are several views which can display the ND2 documents in various ways. Some views are available
for some dimensions only. If a view is available for two or three dimensions of the ND document, a pull-down
menu appears in the top document tool bar. There you can select the dimension to be displayed.

Note

When you switch the view, a new document window opens by default. This behavior can be changed
within the [Edit > Options] command window so that only one view of a document will be opened
at a time.

Main View
When you open an ND2 file, it opens in this view.

Maximum/Minimum Intensity Projection View
These projections analyse all frames of one dimension and pick pixels with the maximum/minimum
intensity values. These pixels are used in the resulting image. (Requires Z or T dimension)

Slices View
This view displays orthogonal XY, XZ, and YZ projections of the image sequence. (Requires Z or T dimen-
sion)

Volume View
This view creates a 3D model of the acquired object. (Requires Z dimension)

Tiled View
This view displays frames of the selected dimension arranged one next to other. (Requires Z, T or XY
dimension)
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6.1.3.4. Tiled View Options

You can change the way the tiles are displayed. Press the [Layout Settings] button in the top document
tool bar. The following window appears:

Layout Options

Automatic
Calculates the number of columns automatically.

Number Of Columns
Define the number of columns by entering a value.

Stage Coordinates
Frames of a multi-point ND document can be displayed in the layout matching the XY stage positions
which were used during the acquisition.
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Direction of drawing
Define whether the thumbnails are displayed in rows or a meander. Also define in which corner shall
the first frame be placed.

Numbering

Numbers may appear on the tiles if you wish. Set the options here:

Type
Select whether and how the numbers/letters are displayed in tiles:

• None

• Numbers

• Uppercase letters

• Lowercase letters

Position
Specify the text area position within the tile.

Text
Define text color and select a font.

Background
Define background color of the text area inside.

Other Options

Highlight current frame
Check this item to highlight the currently selected frame by a red frame.

Show image data
Check this item to display the information under each frame.

Space between tiles
Check this item to keep the tiles apart by a distance. Define the space size between the tiles in pixels.

Use background color from Options/Appearance
Check this option to use the default background color for the tiled view. Otherwise, you can pick any
color from the [Background color] palette.

Header/Footer
A header/footer can be displayed within the tiled view. Select the check-box to enable this feature.
When you place the cursor over the header/footer area, a button appears, press it to switch to edit-
mode.

Background Color
Select the header and footer background color.
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6.1.3.5. View - Examples

Main View, Max/Min Intensity Projection View

Volume View
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Slices View

Tiled View

6.1.3.6. Synchronizer
Synchronizer enables to compare (run and view) two or more ND2 documents at the same time. It automat-
ically synchronizes view of all documents added to the list. Run [View > Visualization Controls > Syn-
chronizer]:

75

User's Guide



• Open at least two ND documents you would like to observe.

• Use the [Add All] button to add them to the synchronizer table. In case there are more documents

opened, use the [Add Current View] button instead. The ND2 file being added must be active.

• The names of selected documents appear in the [Synchronizer] window.

All documents added to Synchronizer are automatically being synchronized.

• Set one of the selected documents active.

• Any action regarding the view (Z position, displayed frame, etc.) is performed on the other documents as
well as on the active one.

• To remove a document from synchronizer, click the reset button next to its name.
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6.1.3.7. ND2 Documents Processing
Most of the image processing and binary image processing commands can be applied to one frame, all
frames, or selected dimension of the ND2 document. When you use such command with ND2 file, the fol-
lowing options are added to its window:

Single Image
The operation will be performed on the current frame of the ND2 document.

All Images
The operation will be performed on all frames of the current ND2 document.

Selected Dimension
The operation will be performed on all frames of the selected dimension.

Note

When you have a document containing T and Z dimensions. Selecting the Z-Series dimension
performs the operation on all Z frames of the current T loop.

If you selected some of the frames/loops of the ND document bymouse, the [Selection] option appears
in the pull-down menu. Opt for it to process only these selected (green highlighted) frames/loops.
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6.2. Working with Documents
It is possible to work with multiple image documents opened at the same time.

6.2.1. Opening Saved Files
NIS-Elements AR offers several ways to open an image file, using either:

The Open Dialog-box
To invoke the Open dialog box, you have the following options:

• Select the [File > Open] command...

• Press [Ctrl + F12] keys simultaneously...

• Press the [Open] button located in the main tool bar

Organizer
An image can be opened by double clicking its filename within [Organizer]. Press [F10] to display the
Organizer mode. Please see the [Organizer] chapter for more details.

Recent Files List
You can quickly access the last opened images using the [File > Recent files] menu.

Open next/previous/first/last Commands
These commands enable you to continuously open the next or previous images from a particular directory
or a database table. The commands are located in the [File > Open/Save Next] menu.

Auto Capture Folder
The [Auto Capture Folder] is a control window that can be displayed by calling the [View > Acquisition
Controls > Auto Capture Folder]. It displays images of a selected folder. To change the folder click

the button in the top left corner of the control window and browse for another folder. Any image
of this folder can be opened by double-clicking its thumbnail.

Any File Manager
During installation, NIS-Elements AR creates file associations to files that are considered its native
format for storing images (JPEG2000 , ND2). The JPEG2000 (JP2) and ND2 image files can be then
opened in NIS-Elements AR just by double clicking their names within any file manager or the desktop.

Opening Files in Progressive Mode

If the image to be opened (a single frame in case of ND2 documents) is too big - so that it can not be loaded
to RAM in one piece - you will be asked whether to open it in a [Progressive Mode]. This means that only
a thumbnail of the image will be loaded to RAM. When zooming-in to view image details, the actual image
data of the portion needed will be loaded to RAM progressively (piece by piece). However, many image pro-
cessing functions and commands are disabled in this mode.
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6.2.2. Switching Between Loaded Documents
Commands for managing the opened images are grouped in the [Window]menu. The recently opened files
are listed in its bottom part. The currently displayed image is indicated by the selected radio button. To
change the current image, select it from the list or use the [Next] or the [Previous] command (represented
by [Ctrl + Tab] and [Ctrl + Shift + Tab] shortcuts).

Document windows can be also arranged automatically using the [Tile horizontally] or [Tile vertically]
commands. This will change the size and position of the opened documents and they will be arranged next
to each other in the selected direction.

6.2.3. Closing Documents

• The currently displayed image can be quickly closed by pressing the cross button in the top-right corner
of the document window.

• The image can be also closed by invoking the [Window > Close] command or by pressing the [Ctrl+F4]
shortcut.

• If you want to close all images, use the [Window > Close all] or the [Ctrl+Shift+F4] shortcut.

• If you try to close an image that has been changed, NIS-Elements AR will display a confirmation dialog
box, offering to save the changes.

• Use the [Window>CloseAll but Current] command to close all opened documents but keep the current
one opened.
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6.2.4. Copying Channels by Drag and Drop

1)

Drag one of the channel tabs and drop it:

• to another image, so it will become a multichannel image;

• inside the NIS-Elements AR application window in order to create a new document

2) Even the [All] and [RGB] tab can be copied.

Note

When extracting a channel from Live image, it does not freeze the camera signal.

ND2 Documents

1) Drag one of the channel tabs and drop it by the [left mouse button]. It behaves the same way as
if performed on a single image.

2) Drag one of the channel tabs by the [right mouse button] and drop it to the application screen. A
context menu appears that enables you to select whether to create the new document from all frames
or just a single frame.

3) [Two ND2 documents] that have matching structure can be [merged into one] easily. E.g. two
single channel Z stacks with the same number of Z positions can be merged into a single two com-
ponent ND2 Z-stack by dragging one into the other.

4) Drag one of the channel tabs of a [single image] and drop it [to an ND2 document]. The channel
will be copied to every loop of the ND2 file.

Note

This behavior too takes place when copying channels that do not have matching structure
(just the current frame is copied to every position of the target ND2
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6.2.5. Image Formats
NIS-Elements AR supports a number of standard file formats. In addition, NIS-Elements AR uses its own image
file formats to fulfil specific application requirements.

JPEG2000 Format (JP2)
An advanced format with optional compression rates. Image calibration, text descriptions, and other
meta-data can be saved together with the image in this format.

ND2 Format (ND2)
This is the special format for storing sequences of images acquired during ND experiments. It contains
various information about the hardware settings and the experiment conditions and settings. It also
maintains all image layers of course.

Joint Photo Expert Group Format (JFF, JPG, JTF)
Standard JPEG files (JPEG File Interchange Format, Progressive JPEG, JPEG Tagged Interchange Format)
used in many image processing applications.

Tagged Image File Format (TIFF)
This format can save the same amount of meta-data as JPEG2000. TIFF files are larger than JPEG2000
files but are loaded faster. TIFF files have several ways to store image data, therefore there are many
versions of TIFF. NIS-Elements AR supports the most common TIFF modalities.

CompuServe Graphic Interchange Format (GIF)
This is a file format commonly used on the Internet. It uses a lossless compression and stores images
in 8-bit color scheme. GIF supports single-color transparency and animation. GIF does not support layers
or alpha channels.

Portable Network Graphics Format (PNG)
This is a replacement for the GIF format. It is a full-featured (non-LZW) compressed format intended for
a widespread use without any legal restraints. NIS-Elements AR does not support the interlaced version
of this format.

Windows Bitmap (BMP)
This is the standard Windows file format. This format does not include additional image description in-
formation such as author, sample, subject or calibration.

LIM Format (LIM)
Developed for the needs of laboratory image analysis software. Nowadays, all its features (and more)
are provided by the JPEG 2000 format.

ICS/IDS image sequence
ICS/IDS image sequences are generated by somemicroscopes and consist of two files: the ICS file with
information about the sequence; the IDS file containing the image data. The ICS file must be stored in
the same directory together with the IDS file.
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7. Image Analysis

7.1. Histogram and Look Up Tables

7.1.1. Histogram
A histogram displays frequencies of pixels of a certain intensity value. The intensity values range from 0 to
255 (for 8bit images). A separate curve is created for each color channel. Run the [View > Visualization
Controls > Histogram] command to display the histogram control window:

Source Data

Source data of the histogram can be viewed if you swap to the [Data] tab in the bottom-left corner of the
window. The area from where the histogram is calculated can be restricted. Select one of the following his-
togram modes:

The data are obtained from the whole image.

The data are obtained from within the probe.

The data are obtained from within the current ROI.
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The data are obtained from the image parts under the binary layer.

Export

The source data or the histogram image can be exported to an external file. Display the [Export] pull-
down menu and select a destination. Click the button to perform the export. The [Export ND histogram]

button enables to export histogram data of all frames of the current ND document. The destination
selected in the [Export] pull-down menu is applied.

Note

Please, see the [Exporting Results] chapter for further details.

Appearance

The histogram can be zoomed in and out using the zoom buttons on sides of the window. There are also
other options to adjust the graph appearance:

• [Left slider] - there is a slider along the Frequency axis. Drag it in order to stretch the view of either lower
or upper values of the axis.

• [Drawing style] - There are two ways the histogram can be drawn:

• [Raw Data] - tries to draw the source data precisely to the graph

• [Trend Style] - interpolates the data so that the histogram lines appear smoother.

• [Auto Scale Vertical] zooms the graph of each channel separately to fit the available area. When
this function is ON, the histogram is not proportional.

• [Auto Scale Horizontal] zooms the graph so that the marginal zero frequencies, if there are some,
are excluded from display.

• [Graph Linear] displays the linear scale on the Y axis.

• [Graph Logarithmic] displays logarithmic scale on the Y axis.

• [Show Grid] turns ON/OFF the grid in the background.
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The graph appearance can be modified. Press the [Options] button - a window appears where the fol-
lowing settings can be adjusted:

Colors
Graph background and axes colors can be selected.

Pen Width
Set the width of the histogram(s) line to 1, 2, or 3 pixels.

Fill Graph Area
The area below the histogram line can be filled with the channel color.

Graph Area Opacity
Select the opacity of the Graph Area color in %.

Vertical/Horizontal AutoScale, Show Grid
These options equals the corresponding buttons of the histogram tool bar.

Interpolation method
Select the way of drawing the graph line. The [Linear] (smooth) and [Quick] (precise) options are
available.

AntiAlias
Smooths the edges of the graph line.

Horizontal axis always visible
If checked, the axis does not leave the graph area while zooming in the graph.

Overrun Indication

If certain amount of pixels with maximum/minimum intensity values (black/white pixels) are spotted in the
image, color dots appears above the graph. The color indicates which channel is affected. When you place
the mouse cursor over the dots, a tool tip message appears with details about the percentage of under/over-
exposed pixels. The percentage limit setting is loaded from the LUTs settings (the color dots do not appear
unless the set percentage of black/white pixels is exceeded).

Note

If the overrun concerns more than three channels (considering multi-channel images), only one
white dot is displayed instead of many color dots.

7.1.2. LUTs
A look-up table is a useful tool for image color and brightness modifications. You can use LUTs to enhance
images for observation purposes so the color modifications will be non-destructive to the image data. LUTs
settings are saved along with the image document. If required, the LUTs settings can be applied to the image

data by pressing the button. The following actions are available within the LUTs window:

• Adjusting the [Gamma parameter]. The gamma curve is drawn in gray over each graph. You can drag
the middle point and move it up or down, or enter an exact value to the [G:] field above.
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• Adjusting the input intensity range. The input intensity range can be restricted by moving the black and
white triangular sliders to the center. All pixels with values outside of the modified input range will be set
to maximum/minimum values and the remaining pixels will be approximated in order to fill the output
(full) range.

Note

This is the way how images can be equalized. For example, if the image is very dark and most
of the histogram is located to the left while the right part of it is flat, you may move the white
slider(s) to the position where the histogram line starts to rise. This will incredibly brighten the
image and reveal details which were previously hidden in a dark.

• Optimal (automatic) zoom of each graph can be set by right-clicking on one of the sliders.

• You can adjust the histograms height non-proportionally by moving the slider on the left of the window up
and down.

Tips

• Right-click the graph area and (de)select [Draw trend style]. When ON, the LUTs curves will be smoothed
to display the data trends rather then represent the actual image data values.

• The position of the black, white and Gamma sliders can be reset by a double click.

Different controls will be available when applying LUTs to monochromatic, RGB, multi-channel or spectral
image. When LUTs are active, the LUTs button in the top-left corner of the document window is highlighted
red.
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7.1.2.1. LUTs on RGB Images

There are 3 separate windows for each of the RGB channels. All channels are controlled at the same time
by default. To control each channel separately, press and hold the [Shift] key while you drag the sliders or
adjust Gamma.

LUTs Tools

Enable/Disable LUTs
This button applies LUTs to the current image.

Keep Auto Scale
Press this button to run the auto scale procedure permanently (on the live image). When you turn this
button OFF, the settings remain as if the [Auto Scale] button was pressed only once.

Auto Scale
This button adjusts the white slider position of all channels automatically with the purpose to enhance
the image reasonably. If you have selected the [Use Black Level] option from the [Settings ]pull-down
menu, the black slider will be affected too.

Reset
Discard all LUTs settings and turn LUTs OFF by pressing this button.

Settings
Display the pull down menu and select one of the following commands:
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• [Use Black Level] - Check this item to ensure that the black slider will be affected by the auto scale
functions .

• [Settings] - opens the [Auto Scale Settings] window. See Auto Scale Settings.

Keep Auto White Balance Check Box
Check this option to switch the Auto White Balance functionality permanently (on the live image).

AWB
Press this button to perform the Auto White Balance operation once.

Auto White Balance Color (...)
This button Opens the [AWB Color] window and enables you to select a color shade which the system
shall eliminate (make white). See AWB.

Reset Components
Discard all AWB settings with this button.

Color Oversaturation
Switch this button ON and the system highlights all pixels with values reaching maximal values. Select
colors to highlight the pixels with in the pull-down menu.

These buttons arrange histograms of single channels next to each other horizontally or vertically.

(-LO- option)
This button arranges histograms of single channels overlapped. Use sliders at the bottom of the graph
window to amplify or reduce the green/red/blue component display in the view.

Save/Load LUTs
This pull-down menu enables user to handle LUTs settings in various ways. They can be saved to a
[*.lut] file and loaded later. Or, LUTs settings saved along with an image document can be loaded directly
from this document by the [Reuse LUTs from File] command. Or you can copy/paste the settings
within the documents opened in NIS-Elements AR (the copy/paste .

Modify Image Through LUTs

Press this button to apply the LUTs settings to the image data - the original image will be overwritten.
Until you press this button, no changes are made to the image data.
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Auto Scale Settings

Press the arrow next to the [Reset LUTs] button and a pull-down menu appears. Invoke the [Settings]
command.

The [Low] and [High] fields determine how many of all pixels of the picture are left outside the sliders when
[Auto Scale] is applied (0-10%).

AWB

White color in some images may suffer from having a color tint. The AWB (Auto White Balance) mode adjusts
the image to get pure white instead of this tint. Similarly to LUTs auto scale, the AWB function can be used
once, or permanently on the live image. If you know the tint your “white” color has, you can select this color
by the color picker that appears after pressing the [...] button:

Choose the color by mouse. You can also enter the RGB values to the fields below. A preview of the chosen
color appears in the rightmost rectangle.
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7.1.2.2. LUTs on Monochromatic Images

All features mentioned above are also valid for monochromatic images, except that the [AWB] function is
not available. There are some other features added when in “mono” mode.

Mapping Mode
The Mapping mode pull-down menu enables you to select how the intensities overreaching the white
slider setting will be displayed. Choose the mapping mode:

In the [Contrast mode], the pixels with values higher than the white slider level will be displayed white,
unlike in the [Window mode] where they will be displayed black.

Gradient
Mappingmonochromatic images to pseudo-color gradients is often used to enhance details in the image
which would otherwise not be obvious. This button indicates the currently selected gradient. When
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pressed, a pull-down menu appears where you can select the color scheme you would like to use. Try
a few of the schemes to see which one suits best.

7.1.2.3. LUTs on Multichannel Images

LUTs window on two-channel image

Most of features mentioned above are also valid for multi-channel images. There are some other features
added when in “multi-channel”mode. Each channel is controlled separately by default. To control all channels
at the same time, press and hold the [Shift] key while you drag the sliders or adjust Gamma.

When the image contains up to three channels, all channels can be visible at one time and you can handle
them similarly to the RGB mode. When there are more than three channels, only one channel is displayed
at one time. A pull-down menu in the tool bar enables you to select the channel to be displayed.
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Next to the channel selection pull-down menu, there is this [Auto Scale] button. By pressing it, the
system will automatically adjust only the current channel settings.

7.1.2.4. LUTs on Spectral Images
When observing a spectral image, the graph inside the LUTs window does not show the image histogram(s),
but reveals another information about the image. Intensity values are on the Y axis and spectra is on the X.
There are two curves in the graph. The top (white) curve displays the maximal intensity and the color curve
displays the mean intensity of each channel.

Note

Spectral image consists of many channels, each representing a single wavelength.

The LUTs behavior depends on the selected displayingmode. There are four displayingmodes. You can select
the mode either by a pull-down menu in the LUTs tool bar, or within the document top tool bar.

• [True Color]

• [Custom Color]

• [Grouped Color]

• [Gray Scale]

In the bottom part of the LUTs window, [Gain] and [Black Level] settings can be adjusted either for all
channels together or for each group separately - depending on the displayingmode. Gain brightens the image
and the Black Level works just like the left (black) on RGB/mono images.

Note

Each slider (gain or black level) offers a range of values to be set by moving it, but any higher value
can be entered in the field next of the sliders.

TD channel

A spectral image can contain additional TD (transmitted detector) channel. Its basically a standard mono-
chromatic image. LUTs settings of this channel appear on the right edge of the LUTs window.
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True Color Displaying Mode

You can switch to this displaying mode by clicking the button located in the document tool bar.

Custom Color Displaying Mode

You can switch to this displaying mode by clicking the button located in the document tool bar. You can
assign custom colors to sections of the spectrum. Sections (colors) can be added/removed by clicking the
[+] and [-] buttons placed below the spectral graph. To change the section color, click the button located in
the color stripe. A window appears where you can select the color from a palette or define it by [Hue] or
[Wavelength] settings.

Grouped Displaying Mode

You can switch to this displaying mode by clicking the button located in the document tool bar. This
view enables you to reduce the number of channels multiple-times. You can adjust the number of groups by
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the [+] and [-] buttons and also change each channel width by moving the white horizontal dividers. Gain
and Black Level for each group can be adjusted.

Gray Scale Displaying Mode

You can switch to this displaying mode by clicking the button located in the document tool bar. The
image is displayed in gray scale, but various color gradients can be applied to it.
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7.2. Thresholding
Specifying correct threshold limits is a crucial procedure of the automated image analysis. The point is to
determine which pixels will and which will not be included in the binary layer and thereby distinguish objects
to be analyzed from background. To display the thresholding control window, run the [View > Analysis
Controls > Thresholding] command. Thresholding can be performed in the following modes:

7.2.1. RGB Mode
The [RGB] thresholding mode is available only if an RGB image is opened. There are two ways how to define
the threshold limits, by choosing reference points within the image, or by defining the limit values for each
color channel.

To threshold the image use the following tools:

• This button invokes a pull-down menu which enables to load/save the current threshold settings
from/to an external file (*.threshold).

• This button displays/hides the [Size] and [Circularity] restriction bars.

• This button erases the threshold settings (no binary objects are created).

• Single point threshold tool. Select it and click inside the image to define the threshold. The threshold
ranges will be adjusted so the selected pixel will fit inside.
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• 3 point circle tool picks threshold from the radius of 3 pixels.

• 6 point circle tool picks threshold from the radius of 6 pixels.

• Undo - reverses the previous threshold operation.

• Redo - returns the threshold as it had been before the [Undo] button was used.

• Rethreshold image - use this button to update the binary layer according to the current settings. The
purpose of this button is to obtain the original binary layer in case it has been modified e.g. by a command
from the binary layer.

• Keep Updating Binary - press this button to keep the binary layer up-to-date all the time. You may find
this function useful especially when thresholding is applied to the live image.

• Threshold ND image - when an ND2 document is opened, this button appears. Define the threshold
limits on the current frame and use the button to apply it on the whole ND2 document.

Threshold Adjustments

Thresholding parameters can be adjusted very precisely in the following way:

• Threshold limits of each channel can be adjusted by rewriting the values in the top-left/top-right corner
of each channel histogram.

• Threshold range of each channel (the colored stripe) can be shifted by mouse. Place the cursor in the
middle of the range (a circle appears) and drag it left or right.

• Threshold limits of each channel can be adjusted by mouse. Place the cursor on the edge of the
thresholding range and drag it left or right.

The two last behaviors can be further modified by pressing additional keys:

• Move the threshold using the right mouse button - the binary layer in the image is not updated continuously,
but is updated only once after the mouse button is released. Such operation saves some computing and
therefore is quicker.

• Hold [Shift] while moving the threshold limits - the threshold adjustment is performed on all channels
together (RGB images only).

• Hold [Ctrl] while moving the threshold limits - both the low and the high threshold limits move in opposite
directions.

Binary Operations

Three basic operations can be performed on the binary layer before it is displayed on screen. To turn the
operation on, click on the up arrow button in order to define the number of its iterations:
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• [Clean] - removes small objects from binary image.

• [Smooth] - smooths the binary image contours.

• [Separate] - separates objects.

See [Mathematical Morphology Basics ].

7.2.2. HSI Mode
The [HSI] thresholding mode is available only if an RGB image is opened. The thresholding procedure works
the same way as in the RGB mode except that the pixel values are displayed in the HSI (Hue, Saturation,
Intensity) color space and that the [Saturation] and [Intensity] channels can be switched OFF. Therefore
you can threshold over the [H], [HS], or [HI] channels only. Switch the channel off by de-selecting the check
box in the top-left corner of the channel histogram.

7.2.3. Intensity Mode
The thresholding procedure works the same way as in the RGB mode except that it is performed on the in-
tensity pixel values.

7.2.4. MCH Mode
The [MCH]mode is not available when working with a monochromatic (single channel) image. This mode is
dedicated to perform threshold on multichannel images, but can be applied to RGB images as well.

• If there are many channels, only one channel histogram is displayed. Switch between the channels by
selecting their names from the bottom pull-down menu.

• The binary layer(s) can be displayed in two modes:

1. Each channel can create its own binary layer

2. One layer can be created as an intersection of all channels binaries.
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7.3. Binary Layer
The binary layer, as a result of thresholding, can be modified by hand using the binary layer editor. It is a
built-in application providing various drawing tools and morphology commands. Go for the [Binary > Binary
Editor ] command or press [Tab]. New buttons appear on the tool bars:

7.3.1. Controls (horizontal tool bar)

• Reverses the changes made to the binary image. [U]

• Clears the binary image (fills the entire image with the "background" color). [R]

• Loads the image previously saved by the [Save] button. [L]

• Temporarily saves the current binary image. It can be loaded anytime before the binary editor is
closed by the [Load] button. [S]

• Displays this help page.

• Stores the changes and quits the editor. [ESC] or [TAB]

The other buttons of the horizontal tool bar are simplified versions of mathematical morphology functions:

• Dilate

• Erode

• Close

• Open

• Separate Objects

• Clean

• Fill Holes

Please see the [Mathematical Morphology Basics ] chapter.

7.3.2. Drawing tools (vertical tool bar)
The binary image can be modified using various drawing tools. Although the way of use of some tools differs,
there are some general principles:
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• Make sure you are in the right drawing mode (drawing background /foreground )

• Drawing of any object which has not been completed yet can be canceled by pressing [Esc] .

• The polygon-like shapes are drawn by clicks of the left mouse button. The right button finishes the shape.

• The automatic drawing tools (threshold, auto detect) have a changeable parameter. It can be modified by
[+] and [-] keys or by mouse wheel.

• The scene can be magnified by the UP/DOWN arrows when mouse wheel serves another purposes.

• You can drag a magnified image by right mouse button.

• A line width can be set in the top tool bar.

• Hints are displayed in the second top tool bar.

Drawing Tools

• Switches between the foreground and the background editing mode. [Ctrl+SPACE]

• The Hand tool. Serves for moving the image when magnified. [Ctrl+W]

• Bezier hollow tool. The object is defined by placing points on its perimeter. The lines connecting those
points can vary from straight lines to Bezier curves. (Use +,- keys to adjust them). To finish creation press
the right mouse button. [Ctrl+F11]

• Bezier fill tool. It equals the Bezier hollow tool, but the resulting object is filled. [Ctrl+F12]

• Draws a filled polygon. While holding the left mouse button down, you are in the free hand mode.
When you release it, each click defines a corner of the polygon. The polygon is enclosed and filled by
pressing the right mouse button. [F4]

• Draws a polygon. It equals the Filled polygon tool, but the resulting object is not filled. [F3]

• Draws a filled circle. Click to determine the center and define the perimeter holding the left mouse
button down. [F8]

• Draws a circle. Click to determine the center and define the perimeter holding the left mouse button
down. [F7]

• Draws a filled circle defined by three points placed on the perimeter. [Ctrl + F8]

• Draws a circle defined by three points placed on the perimeter. [Ctrl + F7]
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• Draws a filled rectangle. [F10]

• Draws a rectangle. [F9]

• Draws a filled movable circle/ellipse. If you grab the ellipse by the center, you can move it. If you grab
it by the border, the nearest semi-axis is being modified. When holding down either the [SHIFT] or the
[CTRL] key, both semi-axes change equally (forming a circle). [F12]

• Draws an ellipse. [F11]

• Drawing by hand. [F1]

• Draws a straight line. [F2]

• Draws a polyline. [F5]

• The Auto Detect filled tool. Detect hollows using threshold techniques. Click to the image to place
the probe, the detected area is drawn. You can adjust the thresholding range by using the mouse wheel
or by pressing the +, - keys. [Ctrl+B]

• Threshold tool. Click into the image to place the probe (or more of them) to define the initial color
level for thresholding. Pres +,- keys or use the mouse wheel to change the thresholding range. [J]

• Fill an enclosed shape. [F6]

• Area of interest. All objects outside the selected region will be erased.

• Text tool. Displays dialog box for defining text parameters.

• [Commands] tool. The last button in the left tool bar displays the currently selected tool. You can invoke
a pop up menu and select one of the additional commands:

Commands

• The Auto Detect hollow tool. Detect hollows using threshold techniques. Click to the image to place
the probe, the hollow is drawn. You can adjust the thresholding range by using the mouse button or by
pressing the +, - keys.

• Draws rectangularly crossed lines.

• Draws a rose. Click to the image to define the center, than drag the mouse to set the length of it's
arms.
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• Places a marker to the image. Simply click into image...

• Selects binary objects.

• The Connect tool. Draws a line(s) from the place you've clicked to the nearest object(s).

• Displays a grid. Visible only when using magnification 400% and higher.

• [Smooth] - see the [Mathematical Morphology Basics ] chapter.

• [Contour] - see the [Mathematical Morphology Basics ] chapter.

• Inverts the binary image. Foreground becomes background and vice versa.

7.3.3. Binary Layer Color and Transparency
When in overlay mode:

• The [Insert] key switches between predefined overlay colors.

• [Ctrl + Up/Down] increases/decreases the binary layer transparency.

7.3.4. Erasing Single objects
Single binary objects can be erased in the following way:

• Run the [View > Analysis Controls > Binary Toolbar] .

• Select the [Delete Object] tool from the toolbar.

• Click inside the objects to be erased.

7.3.5. Multiple Binary Layers
An arbitrary number of binary layers can be created within one document. Click this [Create New Binary

Layer] button to add a new binary layer. The binary layer that you are currently editing can be selected
in the nearby pull-down menu. Binary layers can be managed from the [View > Visualization Controls >
Binary Layers] control window.
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7.4. Measurement

7.4.1. Calibration
Calibration of the image is of crucial importance to measurement. A distance will be assigned to one pixel
so that correct and realistic measurements can be performed and objects of different images could be
compared to each other. A correct calibration has to be made before you begin to measure.

7.4.2. Rough Measurement
Quick and approximate measurements can be performed utilizing graticules. They behave like adjustable
floating rulers. User can simply align a graticule with the measured object and read the distance value (e.g.
the diameter). To activate the graticule, press the [Graticules] button.

Select Graticule Type

The type of the graticule ruler is indicated by a picture on the [Graticules] button placed on the right document
tool bar. To change the graticule type, click on the graticules button with the right mouse button and select
the appropriate item from the context menu:

• Rectangular Grid

• Circle

• Simple Circle

• Cross

• Industrial Cross

• Simple Cross

• Vertical Ruler

• Horizontal Ruler

Define Graticule Properties

Right click the [Graticules] button and select the [Graticules properties] command from the pull-down
menu. A window appears where display parameters (shape, color, line width, density of lines) of all graticules
can be adjusted.

Graticules Density
The density value - the closest distance between two line intersections of the graticule - can be set, or
you can let NIS-Elements AR adjust it automatically according to the current zoom factor. The units se-
lection depends on the image calibration (calibrated/uncalibrated).

102

NIS-Elements AR



Measure the Image

The graticule measurement provides the following options:

• The graticule can be moved by mouse arbitrary.

• The graticule position can be reset by using the [Move Graticules to Center] command from the context
menu.

• A binary layer can be created from the current graticule using the [Copy Graticules to Binary] command.

• A [Graticule Mask] can be created from the current binary layer using the [Copy/Add Binary to
Graticule Mask] command.

• A [Graticule Mask] can be stored/loaded to/from an external file via the [Save Graticule Mask As]
and [Open Graticule Mask] commands.

• A new image containing graticules can be created by the [Edit > Create Full View Snapshot] command.

7.4.3. Manual Measurement

Length, area, angles, taxonomy, counts, circle radius, and ellipse semiaxes can be measured manually over
an image. The results are being recorded to a simple statistics table, which can be exported to a file or clip-
board. Also, the data can be presented as a graph.
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• Run the [View > Analysis Controls > Annotations and Measurements] command. The manual
measurement control window appears.

• Select a tool corresponding to the feature you are going to measure. There are several tools for measuring
each feature.

• Measure the objects in the image using mouse.

• Select where to export results in the [Export] pull-down menu.

• Export the results using the [Export] button.

Example Procedure

Measurement of the image of a grain:

1) Select the [Horizontal parallel lines] tool.
2) Place the first line on the top edge of the crystal by clicking into the image. The position of the line

can be adjusted while you hold the left mouse button down. After you release it, the line is positioned.
3) Repeat this to place the second line on the bottom edge of the crystal.
4) When finished, an arrow is drawn between the lines, and the result of the measurement is attached.

A record with the measurement type and the measured value is added to the results table.

Please find details about the measurement tools in the electronic documentation of NIS-Elements AR.

7.4.4. Automated Measurement
Automated measurement is the most powerful of image analysis features. In combination with user macros,
NIS-Elements AR can become a semi- or fully-automatic image analysis tool. There are several key procedures
which a proper automated measurement should involve:

• Optical system calibration (see the [Optical Configurations] chapter)

• Image acquisition. (see the [5 Capturing] chapter)

• Defining threshold, creating the binary layer (see the [Thresholding ] chapter)

• Performing the automated measurement
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• Results presentation

Image Layers Involved in Measurement

The the binary layer and also the color image can get involved in the automated measurement:

• [Binary layer] - is typically used for shape and size measurements (area, perimeter, surface fraction).

• [Color layer] - intensity or hue measurements are carried out on this layer. The area covered with the
binary layer is used as the source data.

Object/Field Measurement

NIS-Elements AR distinguishes two types of automated measurements: object and field.

Object Measurement
Groups of neighbouring pixels of the binary layer are called objects. Results of the object measurement
are usually the object data such as Length, Area, CentreX/Y (the X,Y position of the central pixel of an
object), etc.

Field Measurement
Fieldmeasurements produce information regarding the wholemeasurement area (measurement frame,
ROI). Such information can be Area Fraction, Mean Brightness, Density Variation, etc.

Please see the complete list of measurement features in the [Measurement Features ] chapter.

Restricting the Area of Measurement

The area ofmeasurement can be restricted by themeasurement frame or by a user defined region of interest
(ROI).

Region of Interest - ROI
ROI is a user defined area of the image. Whenever the ROI is displayed (by the [Measure > Use ROI ]
command), it is also applied to restrict the area of measurement.

See [Measure > Simple ROI Editor ] [Measure > Raster ROI Editor ]

Measurement Frame
The measurement frame is a re-sizable rectangular frame which serves for bounding the area accepted
for measurement. Turn the measurement frame ON via the [Measure > Use Measurement Frame ]
command.

Binary objects touching edges of ROI or the measurement frame can be treated differently (excluded
from themeasurement or included). This behavior can be specified within the [Edit > Options]window.

Statistics and Data Presentation

NIS-Elements AR calculates basic statistics - mean value, standard deviation and distribution of all measured
features. The features to be measured can be selected in the [Measure > Object Features ] and the
[Measure > Field and ROI Features ] windows. Results of all automated measurements are presented
and can be exported from the [View > Analysis Controls > Automated Measurement Results ] control
window.
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7.5. Regions of Interest - ROIs
In laboratory imaging experiments, users are often interested in just a part of the image. This is when ROIs
come to help in NIS-Elements AR. If a ROI is turned ON, only the ROI area of the image is evaluated by the
automatic measurement commands while the rest of the image is left ignored. We distinguish the following
types of ROI:

Types of ROI

Camera ROI
A rectangular ROI which restricts the live camera image. See [Camera ROI on Live Image].

Vector ROI
A ROI created by the simple ROI editor. It can be freely resized and rotated. See [Measure > Simple
ROI Editor ].

Raster ROI
A ROI created by the raster ROI editor (similar to the binary layer editor - see [Binary Layer ]). The raster
ROIs behave the same as the vector ROIs, but can not be resized or rotated. See [Measure > Raster
ROI Editor ].

Usage of ROIs

The ROIs can be also distinguished according to their purpose. Right-click the ROI and select its purpose
from the context menu:

Standard ROI
A standard ROI restricting the area of measurement used by the automatic measurement functions.

Background ROI
The ROI specifying the background characteristics. This ROI is used as the data source by the [Image
> Background > Subtract Background Using Background ROI] command.

Reference ROI
A special ROI used by the [View > Analysis Controls > Timemeasurement ] control window to reduce
the influence of photo-bleaching on the resulting data.

Stimulation ROI
Confocal microscopes use this type of ROI to aim stimulation lasers.

ROIs in time

When performing time-lapse experiments, the observed objects may be moving. If a ROI has been created
over such object, you can make it move along with the object. Right-click the ROI and select one of these
options:

ROI is global
Position of a global ROI throughout different frames of the ND2 file is static

ROI changes over time
Position of a moving ROI can differ frame by frame. It is definable on an ND2 document. See [ROI in
Time - Moving ROIs].
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7.5.1. ROI in Time - Moving ROIs
To define a moving ROI:

• Open or capture a time-lapse ND document.

• Display the first frame of the document and open the vector ROI editor by the [Measure > Simple ROI
Editor ] command.

• With one of the editor tools, draw the ROI around an object. Close the ROI editor.

• Right-click the ROI and select [ROI Changes Over Time] from the context menu.

• Play the image sequence and if the object of interest starts to move out of the ROI, pause the replay.

• Now it is possible to drag the ROI to the new position. If the ROI is created by the vector editor, its size
and rotation can be also modified.

• Play the sequence further and drag the ROI to a new position each time the object in the image moves.

Note

ROI positions between two user-defined frames are interpolated. If the object of interest was
moving at constant speed with a linear trajectory, then it would be sufficient to define the ROI po-
sitions only in the first and the last frame of the image sequence.

Tips on Moving ROI

ROI Tracking
Motion characteristics of a manually defined moving ROI can be measured using the [View > Analysis

Controls > Tracking (-TRC- option) ] control window. Just click the [Add Moving ROIs] button to
add the current ROIs to the table of objects.

Automatic ROI Definition
Automatic [Tracking] features may be utilized to define moving ROIs. Already tracked objects may be

converted to moving ROIs by clicking the [Binary to ROI] button. See [View > Analysis Controls
> Tracking (-TRC- option) ].

ROI Multiple Selection
Use the Ctrl key to select/unselect more than one ROI. When you have selected more ROIs, press and
hold the [Alt] key while dragging a single ROI. Other selected ROIs will not bemoved but remain selected.
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Editing ROI in time

You can edit ROIs in time using the [Edit ROIs in time] command, which is accessible from the contextual

menu of the [Turn ROI on/off] button (in the right document toolbar).

Use provided tools to edit or create a new ROI:

Move
This tool enables to move the ROI to a different place in the image. As you place the cursor over the
ROI, color of the selected ROI is indicated near the mouse cursor (this proves very useful when you have
defined many ROIs, or they are overlapping). Simply drag and drop the ROI to another position.

Pick
Use this tool to select directly in the image which ROI you want to edit.

Draw
Use this tool to draw a freehand curve which defines new region of interest. Press the right mouse
button to close the curve and finish the definition.

Detect
Enables to redetect ROI or to detect a new ROI (when the [New] button is pressed, or New item is selected
from the pull down menu).

New
Press this button to create a new ROI. According to which detection tool is selected, you can either start
drawing a new ROI, or click inside the image to let the application detect the ROI automatically.

ROI picker
Select which ROI you want to edit from the pull down menu.

After Edit
Specify which action is taken after a ROI has been edited. The [Jump Forward] option displays another
time frame according to set number of frames in the Skip pull down menu.

Skip
Choose how many frames are skipped after an object is edited (and the [Jump Forward] option is se-
lected). Skip 1 frame just moves to the nearest next frame.

Delete
Press this button to delete selected ROI.

Undo/Redo
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Moves back and forth through the history of changes.

Help
Displays help file.

Finish
Press this button to finish definition and close the dialog.
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7.6. Measurement Features
The following list describes all the features that can be measured within NIS-Elements AR Measurements.
Suitable type of measurement (object/field/interactive) and the required image layer (binary, color/binary)
are included in the description. See also [Measurement].

AcqTime
Calling the Grab Sequence command, the AcqTime is set to zero at the beginning. Then, NIS-Elements
AR assigns the AcqTime to every newly grabbed image file header, which denotes time elapsed from
the beginning of the grabbing. If the Grab Sequence command is not called, than the AcqTime is the
time elapsed since the start of NIS-Elements AR .

Measurement Type: object, field

Image Type: binary

Area
Area is a principal size criterion. In a non-calibrated system, it expresses the number of pixels; in a cal-
ibrated one, it expresses the real area.

Measurement Type: object, field, interactive

Image Type: binary

AreaFraction
AreaFraction is the ratio of the segmented image area and the MeasuredArea. It has a strong stereolo-
gical interpretation: in the case of isotropic uniform random sections it is equal to the volume fraction.

AreaFraction = Area/MeasuredArea

Measurement Type: field
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Image Type: binary

Blue
Blue value is themean of blue component pixel values. It is the usual statistical mean of intensity values
of the blue component.

Measurement Type: interactive

Image Type: color

BoundsLeft, BoundsRight, BoundsTop, BoundsBottom
These are distances (X or Y coordinates) of the left, right, top, and bottom edge of the object bounding
rectangle. The units of calibration are used if the image is calibrated. Otherwise, the coordinate value
is in pixels.

Measurement Type: object

Image Type: binary

BoundsAbsLeft, BoundsAbsRight, BoundsAbsTop, BoundsAbsBottom
These are absolute distances (X or Y coordinates) of the left, right, top, and bottom edge of the object
bounding rectangle within a motorized stage range. This feature can be measured only when the motor-
ized stage is connected.

Measurement Type: object
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Image Type: binary

BoundsPxLeft, BoundsPxRight, BoundsPxTop, BoundsPxBottom
These are distances (X or Y coordinates) of the left, right, top, and bottom edge of the object bounding
rectangle. Unlike the BoundsLeft,... distance, this value is always in pixels.

Measurement Type: object

Image Type: binary

BrightVariation
It is the usual standard deviation of brightness values.

Measurement Type: object, field

Image Type: color/binary

CentreX
CentreX is the x co-ordinate of the center of gravity. The units of calibration are used if the image is
calibrated. Otherwise, the coordinate value is in pixels.

Measurement Type: object

Image Type: binary

CentreY
CentreY is the y co-ordinate of the center of gravity. The units of calibration are used if the image is
calibrated. Otherwise, the coordinate value is in pixels.

Measurement Type: object

Image Type: binary

CentreXabs
CentreXabs is the absolute x co-ordinate of the center of gravity within a motorized stage range. This
feature can be measured only when the motorized stage is connected.

Measurement Type: object

Image Type: binary

CentreYabs
CentreXabs is the absolute y co-ordinate of the center of gravity within a motorized stage range. This
feature can be measured only when the motorized stage is connected.

Measurement Type: object
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Image Type: binary

CentreXpx
CentreXpx is the x co-ordinate of the center of gravity. Unlike the CentreX coordinate, this value is always
in pixels.

Measurement Type: object

Image Type: binary

CentreYpx
CentreYpx is the y co-ordinate of the center of gravity. Unlike the CentreX coordinate, this value is always
in pixels.

Measurement Type: object

Image Type: binary

Circularity
Circularity equals to 1 only for circles; all other shapes are characterized by circularity smaller than 1.
It is a derived shapemeasure, calculated from the area and perimeter. This feature is useful for examining
shape characteristics.

Circularity = 4* π *Area/Perimeter2

Measurement Type: object

Image Type: binary

Class
NIS-Elements AR recognizes 12 classes (1-12). If you have selected class feature (function Object
Features or Field Features), system automatically asks you to specify the class via dialog box. In field
or scan objects measurements, the application asks for a class before measurement is performed on
the current image. In single object measurement, NIS-Elements AR asks for a class for every measured
object. In the case you want to pass by, there is a possibility to run the SetClass function.

Measurement Type: object, field, interactive

Image Type: binary

DensityVariation
DensityVariation is derived from density values. It is a usual standard deviation of density values.

Measurement Type: object, field

Image Type: color/binary

Elongation
Elongation is determined as a ratio of MaxFeret and MinFeret features. This feature is useful for shape
characteristics.

Elongation = MaxFeret/MinFeret

Measurement Type: object
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Image Type: binary

EqDiameter
The equivalent diameter is a size feature derived from the area. It determines the diameter of a circle
with the same area as the measured object:

Eqdia = sqrt(4*Area/ π )

Measurement Type: object, interactive

Image Type: binary

ExPurity
This feature specifies the amount of white in themeasured color, if themeasured color can be composed
of white and a pure spectral color.

Measurement Type: object, field, interactive

Image Type: color

FillArea
In case an object does not contain holes then the FillArea is equivalent to the Area. If an object contains
holes, FillArea remains the same while Area is reduced by the area of the holes.

Measurement Type: object

Image Type: binary

FillRatio
FillRatio is the ratio of Area and FillArea:

FillRatio = Area/FillArea

If an object does not contain holes the FillRatio is equal 1. If an object contains holes, FillRatio is less
than 1. This feature can distinguish objects with and without holes.
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Measurement Type: object

Image Type: binary

IntensityVariation
IntensityVariation is derived from an intensity histogram. It is an usual standard deviation of intensity
values. This feature describes the inner structure of an object or a field.

Measurement Type: object, field

Image Type: color

Green
Green value is the mean of green component pixel values. It is the usual statistical mean of intensity
values of green component.

Measurement Type: interactive

Image Type: color

HueTypical
HueTypical is the hue value with maximum frequency in a hue value histogram. This feature describes
the most frequent hue (color) in an object or field.

Measurement Type: object, field

Image Type: color/binary

HueVariation
HueVariation is the usual standard deviation of hue values. This feature describes hue (color) distribution
of inner structure of an object or field.

Measurement Type: object, field

Image Type: color/binary

SumBrightness
SumBrightness is defined as the sum of brightness in every pixel of the object.

Measurement Type: object, interactive

Image Type: color/gray

SumDensity
SumDensity is the sum of individual optical densities (O.D.) of each pixel in the area being measured.
This feature describes, for instance, the amount of a substance in biological sections. Optical density
is evaluated according to the following formula:

O.D. = -log((PixelIntensityValue + 0.5)/62.5)

Measurement Type: object, field, interactive

Image Type: color/binary

SumIntensity
Sum Intensity is defined as the sum of intensity in every pixel of the object.

Measurement Type: object
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Image Type: color/gray

Length
Length is a derived feature appropriate for elongated or thin structures. As based on the rod model, it
is useful for calculating length of medial axis of thin rods.

Length = (Perimeter + sqrt(Perimeter2 - 16*Area))/4

Measurement Type: object, interactive

Image Type: binary

LineLength
Line length is defined as the length of the object with elongated shape.

Measurement Type: object

Image Type: color/gray

Luminance
Luminance is defined as a radiant power weighted by a spectral sensitivity that has characteristics of
human vision.

Measurement Type: object, field, interactive

Image Type: color

MaxFeret
TheMaxFeret is the maximal value of the set of Feret's diameters. Generally (for convex objects), Feret's
diameter at angle α± equals the projected length of object at angle α± , α± (0,180); NIS-Elements AR
calculates Feret's diameter for α± =0, 10, 20, 30, ..., 180.

Measurement Type: object, interactive

Image Type: binary

MaxFeret90
The MaxFeret90 is a length projected across the MaxFeret diameter.

Measurement Type: object, interactive
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Image Type: binary

MaxIntensity
MaxIntensity value is derived from the intensity histogram. It is the maximal of intensity pixel values.

Measurement Type: interactive

Image Type: color/gray

MeanBlue
MeanBlue value is the mean of blue component pixel values. It is the usual statistical mean of intensity
values of blue component.

Measurement Type: object, field, interactive

Image Type: color/binary

MeanBrightness
MeanBrightness value is the usual statistical mean of brightness values of pixels. NIS-Elements AR uses
brightness calibration curve for evaluation of this parameter.

Measurement Type: object, field, interactive

Image Type: color/binary

MeanDensity
MeanDensity value is the usual statistical mean of density values of pixels. NIS-Elements AR uses
density calibration curve for evaluation of this parameter.

Measurement Type: object, field, interactive

Image Type: color/binary

MeanIntensity
MeanIntensity value is derived from the intensity histogram. It is the usual statistical mean of intensity
values of pixels.

Measurement Type: object, field, interactive

Image Type: color/binary

MeanGreen
MeanGreen value is themean of green component pixel values. It is the usual statistical mean of intensity
values of green component.

Measurement Type: object, field, interactive
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Image Type: color/binary

MeanChord
MeanChord is the mean value of secants in the 0, 45, 90 and 135 degrees directions. It is a derived
feature and is calculated from the Area and mean projection according to the following formula.

MeanChord = 4*Area/(Pr0 +Pr45 +Pr90 +Pr135 )

Measurement Type: object, field

Image Type: binary

MeanRed
MeanRed value is the mean of Red component pixel values. It is the usual statistical mean of intensity
values of red component.

Measurement Type: object, field, interactive

Image Type: color/binary

MeanSaturation
MeanSaturation is a statistical mean of saturation values of pixels.

Measurement Type: object, field

Image Type: color/binary

MeasuredArea
MeasuredArea value is the area of themeasurement frame or of amask within themeasurement frame,
if the mask status is on.

Measurement Type: object, field

Image Type: binary

MinFeret
The MinFeret value is the minimal value of the set of Feret's diameters. Generally (for convex objects),
Feret's diameter at angle α± equals the projected length of object at angle α± , α± (0,180); NIS-Elements
AR calculates Feret"s diameter for α± =0,10,20, 30, ..., 180.

Measurement Type: object, interactive

Image Type: binary

MinIntensity
MinIntensity value is derived from the intensity histogram. It is theminimum of intensity values of pixels.

Measurement Type: interactive

Image Type: color/gray

NumberObjects
NumberObjects value returns the number of objects in the measurement frame. Exclusion rules for
counting objects are taken into account.

Measurement Type: field
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Image Type: binary

Orientation
Orientation is the angle at which Feret's diameters have their maximum. The diameters are calculated
with 5 degrees angle increment.

Measurement Type: object

Image Type: binary

Perimeter
Perimeter is the total boundary measure. It includes both the outer and inner boundary (if there are
holes inside an object). The perimeter is calculated from four projections in the directions 0, 45, 90
and 135 degrees using Crofton's formula

Perimeter = π *(Pr0 +Pr45 +Pr90 +Pr135 )/4

Measurement Type: object, field, interactive

Image Type: binary

Red
Red is the mean of red component pixel values. It is the usual statistical mean of intensity values of
red component.

Measurement Type: interactive

Image Type: color

ShapeFactor
This parameter is to define whether the object is rough or not.

Shape factor = 4 π (area)/(Convex hull perimeter)2
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Measurement Type: object

Image Type: binary

StartX
StartX is the x co-ordinate of a pixel on the object boundary. When you scan the image from the origin
as indicated (left->right), the first pixel of the object you hit is the one with StartX and StartY coordinates.

Measurement Type: object

Image Type: binary

StartY
StartY is the y co-ordinate of a pixel on the object boundary.

Measurement Type: object

Image Type: binary

StgPosX
StgPosX feature is the x co-ordinate of the absolute position of the measured field. It is available only
for systems equipped with a stage.

Measurement Type: object, field
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Image Type: binary

StgPosY
StgPosY feature is the y co-ordinate of the absolute position of the measured field. It is available only
for systems equipped with a stage.

Measurement Type: object, field

Image Type: binary

SurfVolumeRatio
SurfVolumeRatio is a feature with a strong stereological interpretation: if you measure on fields that
are sampled systematically and independently of the content of the sections, then the feature is an
unbiased estimator of the surface area of objects (inner structure) per volume of the whole sample.

SurfVolumeRatio = (4/ π )*Perimeter/MeasuredArea

Measurement Type: field

Image Type: binary

Time
Time assigns the time to a field (object) after a measurement has been performed. See the
SetReferenceTime function help.

Measurement Type: object, field

Image Type: color/binary

VolumeEqCylinder
This parameter is based on the rod model. Length is interpreted as height and Width as the base dia-
meter of a cylinder. Bases are considered to be spherical.

VolumeEqCylinder = ( π d2 )*(l-d)/4 + π d3 /6,

where l=max(MaxFeret, Length), d=min(MinFeret, Width).

Measurement Type: object
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Image Type: binary

VolumeEqSphere
Supposing a profile was created as an intersection of a ball and a section that contains the center of
the ball. VolumeEqSphere is the volume of the ball.

VolumeEqSphere = π *Eqdia3 /6

Measurement Type: object

Image Type: binary

WaveLen
Dominant wavelength. This feature is defined as a wavelength of the pure spectral color that is, together
with white, the measured color composed of. The color in the purple must be composed of more than
one pure spectral colors therefore they have no dominant wavelength.

Measurement Type: object, field, interactive

Image Type: color

Width
Width is a derived feature appropriate for elongated or thin structures. It is based on the rod model and
is calculated according to the following formula:

Width = Area/Length

Measurement Type: object
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Image Type: binary
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7.7. Mathematical Morphology Basics
The binary image as a result of thresholding often needs to bemodified before ameasurement is performed.
Edges of the objects can be smoothed, holes in the objects filled etc. by using the mathematical morphology
commands.

Note

“Image Analysis and Mathematical Morphology” by J. Serra (Academic Press, London, 1982) was
used as a reference publication for the following overview.
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The basic processes of mathematical morphology are: erosion, dilation, open, close and homotopic trans-
formations.

Erosion
After performing erosion, the objects shrink. Marginal pixels of the objects are subtracted. If an object
or a narrow shape is thinner than the border to be subtracted, they disappear from the image.

Dilation
After performing dilation, the objects enlarge. Pixels are added around the objects. If the distance
between two objects is shorter than twice the thickness of the border to be added, these objects become
merge together. If a hole is smaller than twice the thickness of the border, it disappears from the image.

Open
Open is erosion followed by dilation so the size of the objects is not significantly affected. Contours are
smoothed, small objects are suppressed and gently connected, particles are disconnected.

Close
Close is dilation followed by erosion so the size of objects is not significantly affected. Contours are
smoothed, small holes and small depressions are suppressed. Very close objects may be connected
together.

Clean
This transformation is also called geodesic opening. The image is eroded first so small objects disappear.
Then, the remaining eroded objects are reconstructed to their original size and shape. The advantage
of this algorithm is that small objects disappear but the rest of the image is not affected.

Fill Holes
Fills the holes inside objects. This transformation is handy when objects have a rich inner structure with
intensities typical for background. After applying the [Fill Holes] transformation, objects become homo-
geneous.

Contour
This transformation converts objects into their contours.

Smooth
Smooth affects rough edges of the objects makes them smooth.

Morpho Separate Objects
This transformation detects standalone objects that are connected together and isolates them.

Homotopic Transformations

Homotopic transformations preserve topological relations between objects and holes inside them. Using a
homotopic transformation, an object with 5 holes will be transformed to another object with 5 holes. Two
objects without any holes, even if they are very near each other, will become again two objects without holes,
but likely with a different shape and size. Opening, Closing, Erosion and Dilation are not homotopic trans-
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formations. Typical homotopic transformations in NIS-Elements AR are: [Skeletonize], [HomotopicMarking]
and [Thickening].

7.7.1. Connectivity
Applying the above mentioned transformations has some limitations due to digital images rasterization.

When speaking about binary image processing, a binary image is a set of pixels where values 1 represent
objects and values 0 represent background. In the square grid of the image, two possible connectivities can
be used for processing - the 8-connectivity or the 4-connectivity. Look at the picture below. If the 8-connectivity
is used, the two pixels represent one object. If the 4-connectivity is applied, there are two objects in the
picture. NIS-Elements AR works with the 8-connectivity model, so all pixels neighboring by the corner belong
to one object.

7.7.2. Structuring Element = Kernel = Matrix
When applying Erosion, Dilation, Opening or Closing, one of the parameters which determines the transform-
ation result is the selection of kernel (structuring element, matrix) type. There are the following kernels used
in NIS-Elements AR:

The bright pixel in the center or near the center of the kernel represents its midpoint.

7.7.2.1. Erosion
Lets assume the 1 and 0 values represent object(1) and background(0) pixels. You can imagine the erosion
as the following algorithm:

Move the midpoint of the kernel to every point of the image. Each time, look at the neighboring pixels of the
kernel and make the following decision:

• If there are object(1) pixels in all the positions of the kernel, set the midpoint to object(1).

• If there is at least one background(0) pixel in the kernel, set the midpoint to background(0).

7.7.2.2. Dilation
You can imagine the dilation as the following algorithm:
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Move the midpoint of the kernel to every point of the image. Each time, look at the neighboring pixels of the
kernel and make the following decision:

• If there is at least one object(1) pixel in any position of the kernel, set the midpoint to object(1).

• If there are background(0) pixels in all the positions of the kernel, set the midpoint to background(0).

7.7.2.3. Open and Close
Open is performed by eroding the image and then applying a dilation to the eroded image. On the contrary,
Closing is performed as a dilation followed by erosion.

7.7.2.4. Repetition issues
If the midpoint is not in the center, applying erosions or dilations by odd number of iterations causes image
to shift by 1 pixel. Normally, the total image shift would be determined by the number of Iterations (in pixels).
NIS-Elements AR eliminates this shift: it changes the position of the midpoint 1 pixel down-rightwards within
the kernel for even operations. For opening and closing it is possible to eliminate this shift totally. However,
if you run the erode or dilate processes again and again using the kernel with even dimensions and odd
number of iterations, then the shift becomes significant.

7.7.2.5. Examples
Please see the following examples of some of the binary functions applied to an image. In the following se-
quence of images, the functions were applied subsequently:
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See another sequence of functions:
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The following examples were created by calling each of the functions separately:

Original Image
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7.8. Object Count
The [Object Count] tool enables users to threshold the image, automatically measure the binary objects,
and export the measured data to a file in a straightforward way. Object count can be performed even on Live
image. Run the [View > Analysis Controls > Object Count ] command to display the following control
window:

7.8.1. Thresholding the Image
The threshold limits shall be defined by picking object-typical colors from the image. Select one of the following
tools:

• [1 point threshold tool]

• [3 points circle threshold tool]

• [6 points circle threshold tool]

Click inside the image to define typical object areas. The system will detect similar parts of the image and
highlight it by color. The threshold limits are indicated in the histogram and can be further modified by
dragging the limit lines by mouse.

Please, refer to the [Thresholding ] chapter for further details on thresholding.

7.8.2. Applying Restrictions
The number of objects that are included in the results table can be restricted by defining limits. Objects
which do not fit these limits will be left out of the result table.

• Right click to the restrictions field to select one or more of the available measurement features.

• Select the restriction feature you would like to define.

• Move sliders below the histogram to set the limits. The limit values are indicated next to the feature name,
and can be modified by double clicking the indicated value.
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• Decide whether the defined interval will be excluded or included - this is done by setting the [Inside/Out-
side] option next to the feature name.

• The nearby check box indicates whether the restriction is currently being applied or not. If applied, the
histogram below is color, otherwise it is gray.

Note

Infinitude can be defined by entering “oo” or “inf”.

Reset
The [Reset] button on the right side discards restriction settings of all features.

Bins
This setting determines the number of columns in the histogram.

Restrictions from the Image

A reference object can be picked from the image and used to set the limit values.

• Select the restriction feature you would like to set by mouse. Lets assume you have selected [Circularity].

• Right click the thresholded object which is going to be used as source. A context menu appears.

• Select whether to [INCLUDE] or [EXCLUDE] the selected object and all others with higher/lower circularity.
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• The restriction will be applied and indicated by colors within the image.

7.8.3. Results
The following results appear in the results table:

• [Total Area] is the area of the whole image in square pixels or square calibration units.

• [Area Fraction] is the ratio between [Total Area] and the area of the thresholded objects.

• [Number of objects] - number of objects after applying restrictions.

• [Table of results] - measurement results for each object are displayed in this table. Select the columns
to display/hide from the context menu which appears when you right-click one of the column captions.

• [#] - number of selected objects is displayed in the left part of the tool bar. One or more objects can be
selected by mouse while holding the [Ctrl] or the [Shift] key.

Tool Bar

There is a tool bar above the results table which contains the following buttons:

• [ Delete selected objects] removes the selected objects. The objects can be selected by mouse
while holding [Ctrl].

• [ Invert selection] deselects objects selected by mouse and vice versa.

• [ Generate binary] erases binary objects which do not meet the restrictions settings.

• [ Export ND data] - when an ND2 file is opened, the thresholding, measurement, and restrictions
are applied to a single frame. Pressing this button will apply it to all frames of the ND2 document and export
the results to a file or clipboard according to the current export settings.
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• [ Save/Load Object Count configuration] invokes a pull-down menu which enables you to
load/save the current object count settings from/to an external file (*.counting).

• [ Keep updating count] refreshes the measured results each time the binary layer changes (e.g.
when the threshold is modified).

• [Export] - the measured data can be exported to clipboard or a file using the [Export] button. Please refer
to the [Exporting Results] chapter for further details.
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7.9. Time Measurement
The time measurement tool enables to record average pixel intensities within ROI(s) during a time interval.
The measurement can be performed on Live camera signal or on a saved ND2 document. Before the
measurement is started, regions of interest (ROIs) shall be defined and turned ON. Run the [View > Analysis
Controls > Time measurement ] command to open the Time Measurement control window.

Quick Guide

• Enable the Measurement ROI by the [Measure > Use ROI ] command.

• Run the [Acquire > Live - Fast] command to display the live camera signal.

• Define ROI(s) within the image. Time measurement will be performed under the ROI areas. Use the
[Measure > Simple ROI Editor ] command or the [Define] tool bar button to open the vector ROI editor
and use the [Measure > Raster ROI Editor ] command to display the raster ROI editor. See [Regions of
Interest - ROIs].

• Once the ROIs are defined, press the [Measure] button - the measurement will start.

• Press the [Stop] button to finish the measurement.

• Export the results via the [Export] button. See [Exporting Results] for further details.

• A snapshot of the graph will be created if you press the [Create Snapshot] button.

Note

If there are toomany ROIs defined and the graph gets confusing, a single ROI (and the correspond-
ing graph) can be highlighted. Right click the ROI name and select [Bookmark this ROI] from the
context menu.
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Multi ROIs, Multi Dyes

The [Multi ROIs] and [Multi Dyes] buttons in the top right corner swap between two measurement modes:

• [Multi ROIs] - Multiple ROIs can be defined. In this mode, data for each ROI are available.

• [Multi Dyes] - In this mode, data for each color channel (averaged from all ROIs) are available.

Creating Meta-Data Graphs

The [Time Measurement] control window can be used to create a graph of any meta-data included in the
ND2 file - the temperature for example.

• Open or capture an ND2 document containing meta-data.

• Define ROIs.

• The [Left/Right] combo boxes become enabled. Choose the data you want to display in the graph. And
start the measurement with the [Measure] button.

• After the measurement finishes, you can overview the graph in the [Graph] tab.

Graph Display

Use the following buttons to adjust displayed part of a graph.

No Split
The graph is not split.

Split Horizontally
Components defined in the [Left] and [Right] pull down menus are displayed separately in two graphs.

Range 0-bitdepth
Range of Y axis is set from 0 to maximal value of image bit depth (e.g. 255 for 8 bit image).

Range 0-max
Range of Y axis is set from 0 to maximal value measured in the component.

Range min-max
Range of Y axis is set from minimal to maximal value measured in the component.
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7.10. Tracking (-TR- option)
Motion characteristics of objects such as living cells can be measured automatically or manually using the
[Tracking] control window. Run the [View >Analysis Controls > Tracking] command to display the control
window:

7.10.1. Automatic Tracking
Define the objects to be tracked. There are two ways to do so:

Note

The higher contrast between the objects and the background, the better results the tracking will
bring. If the contrast in your image sequence is not sufficient, youmay need to perform some image
processing before the tracking.

Object Definition - One by One

Select the frame from which you would like to track an object. Zoom in the image, click the [Define
New] button, and mark the object by mouse:

• Click to the middle of the object and drag the cursor to its edge.

• An auto-detection algorithm will determine the object area according to the pixel intensity values in the
image.

• When the red line which indicates the computer-estimated object edges is around the object edges, release
the mouse button.

• Define as many objects as you would like to, then click the [Finish] button.

Object Definition - All Together

Select the [Define All] button. The definition method is the same as described above, except that the
auto-detection algorithm tries to detect all objects in the image similar to the one you are just defining. After-
wards, some deleting of mis-detected objects may be needed.
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Tracking

When you finished defining objects, run the automatic tracking procedure:

• Select the first frame of the image sequence.

• Press the [Track Automatically] button.

Tracking Options

Click the [Settings] button, the following options window appears. Select the [Detection] tab.

Predicted movement
The tracking algorithm can be optimized for a certain type of movement. In the left half of the window,
select whether the objects aremoving directly, randomly, or moving in circles, changing size and intensity,
or not. These settings may be assigned to a single object or to all of them - select the object (Object1,
Object2, ..., All) from the bottom pull-down menu.

Auto Path Detection
If you redefined or edited an object, only the frames that you were working with are actually affected.
However, you can apply the performed changes to all subsequent frames by turning the [Auto Path
Detection] option ON. The work-flow should look like this:

• Turn the [Auto Path Detection] ON.

• Edit an object in one of the above described ways.
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• The trace from the edited frame to the end is re-traced automatically.

Capture setting
The tracking does not need to be performed on every frame of the image sequence e.g. if the objects
move very slowly, or for other reasons. Select the tracking frequency on the right side of the window
and select which channels shall be used for the tracking from the bottom pull-down menu. A single
channel or [All] channels are the options.

Track disappearing objects
Objects may disappear or seem to disappear from the image during the acquisition. This option tells
the system to try to regain the trail of such lost objects. If this option is disabled, the object track will
be finished where the object has been detected last.

Tracking ROIs

There are two issues regarding regions of interest and tracking:

• Binary objects which you have defined by the [Define New] or [Define All] buttons can be converted to

ROI objects. Press the [Binary to ROI] button to start the conversion. A set of ROIs will be created
for each frame of the ND2 file.

• A ROI area defined on an ND2 sequence may be either global (the same on all frames) or moving - defined
per frame in time. If you have a moving ROI defined, you can perform the tracking using the [Add moving

ROIs] button. See [ROI in Time - Moving ROIs]

7.10.2. Manual Tracking

• Define the objects to be tracked (follow the procedure described in the [Automatic Tracking] portion of
this chapter). Lets assume that you have a 10-frames image sequence and you defined objects [1], [2],
and [3] to be tracked.

• Press the [Track manually] button.

• The objects [2] and [3] disappear momentarily, and the 2nd image from the image sequence is displayed
automatically. The position of object [1] in the 1st image frame is indicated with white color. You are about
to define the object position in the 2nd frame.

• Click to the center of the object to define the position of it in the frame 2.

• Object [2] appears highlighted in white. Define its position in the 2nd frame by another click.

• In this way, you define the trajectory point #2 of object [3] , too.

• Then, the 3rd image frame of the sequence is displayed waiting for the third trajectory point of object [1]
to be defined, etc.
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7.10.3. Object Redefinition
Some objects, especially if they are living cells, can change their image characteristics - fade, change size,
etc - during the motion. In such cases, the automatic tracking algorithm may get confused and loose the
track for a while. This can be manually corrected by the following tools:

Redefine

When an object changes its characteristics so that the system becomes unable to track it properly, use the
[Redefine] button:

• Select the frame of the sequence where the tracking algorithm got lost for the first time.

• Select the object in the [Objects] table next to the graph.

• Click the [Redefine] button and define the object (the object definition is described above).

• Features such as area and intensity characteristic of the object change when redefined - the tracking al-
gorithm uses the new values from the frame where redefinition occurred on.

Edit Objects

The editingmode works similarly as when redefining an object, but does not change the object characteristics,
only the trajectory is changed.

• Switch to the editing mode by pressing the [Edit Objects] button and display object traces by the [Show
Trace] option from the [Settings] pull-down menu.

• Click the point you would like to modify and drag it by mouse to the right position.

7.10.4. Visualization
The following tools help to visualize the tracking process:

Overlay

You might want to see the whole image sequence in one image. The [Overlay] button can display an addi-

tional layer over the current image. To adjust its properties, invoke the [Settings] button and select the
[Overlay] tab in the window. Three types of overlay image can be selected:

• [Maximum Intensity Projection] - pixel values with the same XY coordinates are compared throughout
the image sequence and only the pixels with the highest intensity value are displayed in the layer.

• [Minimum Intensity Projection] - pixel values with theminimum intensities of the whole image sequence
are displayed in the image.

• [Sequence Intensity Projection] - this is a special overlay, which dyes the trajectories by a color scale.
The movement direction and the object velocity become obvious.

[Color] and [Transparency] of the layer can be adjusted.
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Show Trace

• Press the [Show Trace] command from the [Settings] pull-down menu to display colored trajectories
of all tracked objects in the document. The color can be changed within the table of objects.

• Select to [Show Points/Show Names] from the same pull-down menu. Positions of the objects in each
measured frame will be indicated by a cross and a numbered name (Object1, ...).

Click the [Settings] button and select the [Trace] tab to adjust the trace properties:

Line Properties
Select one of the radio buttons which offers to "paint" the trace 1/ [by objects] - each object trace has
different color; 2/ [by velocity/time] - a random color gradient may be defined in order to indicate the
object velocity or the time of its occurrence at a certain place.

Tail Properties
If the [Show tails] option is checked, colored tails appear in the image following each of the traced
objects. The length of a tail indicates the current object velocity. Number of segments that the tail is
composed from and the tail start width can be adjusted here.

Cross Properties
The cross appearance (height and line width) of the [Show Points] markers is adjustable here.

Kymograph

A kymograph displays pixel intensities changes under a defined linear section over time. A trajectory of a
tracked object, or a user-drawn line can be used as the kymograph line.

To create a kymograph by line:

• Select the [Create Kymograph by Line] command from the [Kymograph] pull-down menu. The mouse
cursor changes.

• Draw a line in the image. Finalize it with right-click.

• A new document called "Kymograph" is created.

To create a kymograph on selected objects

• Select one of the objects in the objects table the trajectory of which you want to use for the kymograph
line.

• Select the [Create Kymograph on Selected Objects] command from the [Kymograph] pull-down
menu.

• A new document called "Kymograph" is created.

7.10.5. Measurement
A data set of object features is gathered during the tracking procedure. Common features such as object
area or object position are measured as well as movement-descriptive features such as acceleration and
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velocity. Their complete list is to be found in the [Settings] dialog box. To display it, click the [Settings]
button and switch to the [Measure] tab. The check boxes indicate features that are going to be included in
the [Data] table. Display the [Data] table by clicking the tab at the bottom of the control window (next to
the [Graph] tab).

Define Reference Point

There are three movement-descriptive features which can be measured in relation to a reference point (if it
has been defined). These are the Reference Length, Reference Velocity, Reference Acceleration. If an object
was moving in circles around the reference point, the features will be constant/zero.

• Click the [Define] button. The window disappears.

• Place the Reference point to the image by mouse. The window reappears.

Export

The measured data or the graph can be exported to an external file using the [Export] button. Please refer
to the [Exporting Results] chapter for further details.
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7.10.6. Graph Properties
The appearance and behaviour of the graph can be modified in the [General Graph Properties] window.
Right-click inside the graph area and select the [Options] command from the context menu.

Vertical/Horizontal axes always visible
If checked, the axes do not leave the graph area while zooming in the graph.

Show grid
The grid in the background may be or may be not displayed by selecting this option.

AntiAlias
Turning this option on will make the graph line edges look smooth.

Display graph points (if possible)
Small dots indicating the actual data values position can be displayed on the graph line. The points
appear only if the distance between them is big enough for them to be recognized (they usually appear
when you zoom in the graph).

Interpolation method
The profile line shape may be smoothed out by using an interpolation method. Select one of the three
available: Quick (basic), Linear (smoother), Bicubic (really smooth).

First/Second Line Properties
These settings (line width and style) are applied to the velocity and acceleration graph lines. The [Color
Highlighting] option ensures that the two lines will differ in color.
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7.11. User Macros
Amacro - an executable sequence of commands - canmake the work very effective. NIS-Elements AR provides
a C-like programming language utilizing its internal set of functions. The sequence of functions can be created
either by recording the performed actions, by writing the functions within the macro editor, or by modifying
the command history (the history is recorded automatically during the work). The macro can be saved to an
external (*.mac) file for later use.

7.11.1. Recording a Macro
The fastest way to create a macro is to record it.

• Start the NIS-Elements AR macro recorder by selecting the [Macro > Record] command.

• Perform the series of actions you would like to record.

• Finish the recording by the same command again (its name changes to “Stop Recording”)

• It is recommended to check themacro in themacro editor before saving. Run the [Macro > Edit] command
to display it.

• Save the macro to a file via the [Macro > Save As] command.

7.11.2. Writing/Editing a Macro
If you posses programmers skills, amacro can be written by hand in the built-inmacro editor. Run the [Macro
> Edit] command to display it.

The macro editor provides:

• Direct output to a printer.

• Undo/Redo functionality.

• Command insertion from the list of available commands.
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• Interactive command names list. Press [Ctrl+Space] to display a simplified list of all commands while
typing the macro.

• Syntax hints (parameter types and names) appear as you type a command name.

• Bookmarks can be placed to the code so you can easily roll to the important parts of the macro.

• Breakpoints can be placed to the code. A breakpoint forces the macro to stop the execution at a certain
point so you can check the state of variables and therefore inspect the macro functionality thoroughly.

• Syntax highlighting.

• Help on commands with detailed description.

7.11.3. Creating a Macro from History
You can create a macro using the list of recently performed commands.

1) Run the [Macro > History] command to display the [Command History] control window:

2) Push the [Create Macro] button.
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3) Select what portion of the command history will be used in the macro:

Selection
This option will use only commands which you have previously selected by mouse within the
[Command History] window. Group selection (holding [Shift] or [Ctrl]) is available.

Whole History
All commands listed in the [Command History] window will be used for the new macro.

4) After you selected one of the options, the macro editor appears containing the new macro source
code. Use the editor to fine-tune it.

Note

The [Remove Redundant] command is automatically performed before themacro is opened
in the editor.

7.11.4. Saving a Macro

Use the [Save Macro] and the [Save Macro As] commands in the macro editor to save the created
macro.

7.11.5. Running a Macro
NIS-Elements AR provides several ways to run a macro.

• You can run the current macro loaded to NIS-Elements AR by choosing the [Macro > Run] command or
by pressing [F4].

• A [hotkey] combination (Ctrl+Alt+1,2,3 ... 9) can be assigned to it in the [Macro > Options] window.

• You can run a macro at the beginning of the NIS-Elements AR session, by assigning the [StartUp] flag to
the macro in the [Macro > Options] window.

• You can run a macro saved to a disk by using the [Macro > Run From] command.

• A tool bar button can be assigned to run a macro. See [Modifying Layout].
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7.11.6. Breaking a Macro
The macro execution can whenever be stopped by pressing the [Ctrl+Break] key shortcut.
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7.12. Creating Reports
Report Generator enables the user to create customized reports containing images, measured data, user
texts, graphics, or database entries. PDF files can be created directly fromNIS-Elements AR . When you invoke
the [File > Report > New Blank Report] command, a [Report Generator] window appears.

It provides the following tools:

• Draw line...

• Draw rectangle...

• Draw ellipse...

• Draw Arrow...
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• Insert text field...

• Insert image from file...

• Insert Table

• Insert graph

• Insert bar code

• Align - aligns selected objects to the position indicated on the button by the line

• Center - aligns the selected objects to center

• Distribute - distributes the objects uniformly along the specified direction

• Determines whether to apply the align commands relatively to the whole page or the selected objects
only.

Context Menu Commands

Once you insert an object, its appearance, behavior, and position can be changed via the context menu
which appears on right-click:

• If there are more than one objects selected, the [Group] command makes them to behave as a single
object.

• The [Align or Distribute] commands enable moving objects within the page or align them with another
object(s).

• The [Resize object] commands enables to resize two objects to the same size.

• The [Bring to front] command changes the order of overlapping objects and brings the current object to
front.

• The [Send to back] command moves the object to the bottom layer.

• The [Lock] command locks the object disabling any further changes to it until it is unlocked.

• The [Properties] command opens a window where object properties such as color, background color,
border size and color, object size, font, aspect ratio, alignment, and shape can be adjusted.

Insert images, text fields and other objects to the report.
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7.12.1. Working with Report Objects
When you double-click any of the report objects, a window appears where the properties can be adjusted.
Some properties are common to all types of objects, and some are special.

Common Properties

• The precise position can be determined by defining the XY coordinates of the top-left corner of the object.

• Line and fill colors can be selected.

• Line widths can be adjusted within the range of 0,25 to 6 pts.

• Precise width and height of the objects can be adjusted.

• Rotation of some objects can be adjusted.

Special Object Properties

Ellipse
Minor and major axes lengths can be modified.

Arrow
The arrow tip shape and size can be modified.

Text Box

• Format of the text can be adjusted like in a standard text editor.

• The current date and time can be inserted from a pull-down menu.

Image

• A new picture can be loaded to the image frame via the [Load Picture] button.

• The current image scale is displayed in the properties window. It shows the [ current scale/original
image dimensions] ratio (the image must be calibrated to use this feature).

• A scale bar can be displayed below the image. The position and width of the scale bar can be defined.

Table

• Inner and outer borders can be hidden or displayed.

• Number of rows/columns can be modified.

Graph

• The range of displayed values can be limited by defining the min/max values.
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• Histogram labels can be edited.

Aligning Objects

You can align two objects to the same horizontal or vertical level.

• Select more objects (e.g. by holding down [CTRL] and clicking with the left mouse button).

• Right-click one of the selected objects and select the [Align or Distribute > Align ...] command from the
context menu.

• The objects will be aligned as indicated on the command icon.

• If the [Relative to Page] option is turned [ON], the objects will be aligned to the edges or the center of
the page.

Objects of similar size can be distributed uniformly in the horizontal/vertical direction.

• Select three or more objects.

• Right click one of the objects and select the [Align or Distribute > Distribute...] command from the
context menu.

• Distances between the objects will be adjusted to equal.

• If the [Relative to Page] option is turned [ON], the outer objects will be moved to the edges of the page.

Sizes of objects can be unified too.

• Select two or more objects.

• Right-click the “master” object to the size of which you want to resize the other objects.

• Select one of the [Resize Objects] sub-menu commands.

Dynamic Data

Results of automatic-interactive measurement, graphs, or the current image can be inserted to reports.

• Insert an object which can contain dynamic data (text, picture, table, or graph).

• Right-click the object and select [Insert Dynamic Data/Insert Dynamic Picture] from the context menu.

• A window appears.

• Select one of the available sources, and click [Next] .

• Finish the source definition and click [OK] . The data appear on the report page.
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List of Available Dynamic Data Sources:

• [ Data inserted by user] (available for: image, text, table ) - the system will ask you to type a text or
browse for an image to insert during the report creation. When creating a dynamic object of this type, a
query text which will be used to prompt you for the data can be defined.

• [System data] (available for: text, table ) - enables you to insert some general data such as date, the
name of the user account currently logged in, the page number, or the page count.

• [ Macro] (available for: text, table ) - enables you to insert expressions, values, or results of a macro.

• [ Measurement] (available for: text, table, graph ) - enables you to insert results of automatic/interactive
measurement.

• [ Database] (available for: image, text, table ) - this data source is displayed only when creating a database
report template (see below). It enables you to insert a link to any of the database records.

The real purpose of the dynamic data turns up when creating reports using report templates.

7.12.2. Working with Report Templates
A report template is a layout defining the appearance of future reports, which is ready to be filled with data.
The data can be inserted by the user “on demand” or automatically (dynamic data).

To Create a Report Template

• Run the [File > Report > New Blank Report] command. An empty report appears.

• In the Report Generator, select [File > Change to Template].

• Edit the report template in the same way as a common report.

• Insert the dynamic data where it is appropriate - measurement results to text boxes or tables, the current
image to the image field, etc.).

• Save the report template (*.rtt) via the [File > Save] command.

To Create a Report from Template

• If the template is opened inside the Report Generator, run the [File > CreateReport] command. Otherwise,
use the [File > Report > New Report from Template] command inside the main application window
to open a template from harddisk.

• A report opens and the dynamic data is inserted automatically.

• Save the report, print it, or export the page(s) to PDF using the commands from the [File] menu.

152

NIS-Elements AR



7.12.3. Creating Reports from Database
Pictures of a database together with the associated table data, or common images with the associated
[Image Info] can be exported straight to a report.

• Switch NIS-Elements AR to [Organizer] by the [View > Organizer Layout] command.

• Select one or more images. These images will be inserted to the report.

• Click the [Report] button on the main tool bar. The following window appears:

• In the [Columns] section, you can select fields, which will be included in the report. If you are exporting
images from a database, the database table fields will be listed. If you are exporting images from a directory,
image description items will appear.

• The [Template] portion of the dialog specifies the layout details. If you select the [Standard] template,
images will be organized in rows and columns. It is possible to set the number of columns and rows. If
you select the [Custom] report template, a user report template (*.rtt) can be opened and used for the
report creation. If such report does not exist yet, you can create it using the [Create New] button.

If You Pressed the [Create New] Button

• A wizard appears. Select number of columns and rows of the new report template. Click [Next].

• Select the paper size, page orientation, and define margins. Click [OK] .

• An untitled report template opens containing a grid of images spaced according to the [columns/rows]
settings.
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• Edit the top-left cell of the image grid. You can change the text/image boxes position, size, and mapping.
During report creation, all the other cells of the grid will be filled automatically according to the settings
of the first one.

• A custom header or automatic page numbering can be added to the report.
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7.13. Creating Movies
Movies is one of the possible ways to present data captured using NIS-Elements AR. The following function-
ality is available:

• A real-time movie of a time-lapse process can be captured.

• A sequence of standalone images can be converted to a movie.

• An ND2 file can be converted to a movie.

• A 3D model or a surface view of an object can be set in motion and make a nice presentation movie.

Movies are saved as an [AVI] which can be played back by any standard video player so you do not need
NIS-Elements AR to view them.

7.13.1. Capturing AVI Movie

• Display the AVI Acquisition control window by the [Acquire > AVI Acquisition] command.

• Adjust the advanced settings, especially define the file name and the destination folder.

• Click the [Record] button. The live image appears and recording starts according to the settings.

• Stop recording by the [Stop] button, or wait until the time defined in the [Duration] field passes.

• When stopped, the AVI file remains opened in a new document window.
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Settings

Press the [Advanced] button to view the whole control window and set the following options:

Live
Choose the format of the camera. The Live-Fast or Capture-Quality mode settings will be used while
capturing the AVI movie.

Rate
The number of frames per second of the movie can be defined. Possible values range from 1 to 50 fps.
There is also the [Max Fps] option. When selected, the system captures every frame sent from a camera.
If the frame rate is beyond hardware capabilities of your system, some frames will be omitted.

Duration
Several predefined lengths of the movie may be selected (60 min, 10 min, 1 min, 10 s) or the [Infinite]
option is available. When selected, the movie will be captured until the [Stop] button is pressed or the
hard drive is filled to capacity.

File - the path and the name
Define the path to a directory and the file name of the AVI file. If you capture more then one movie
without changing the file name setting, the other files will be numbered automatically.

File - Codec
It is common to encode (compress) movies in order to save some disk capacity. This can be done using
various types of codecs. Press the [Open] button on the right and a window appears. Select one of the
codecs available in the system or use the [Default] option. Remember that the codec you choose will
be required for the AVI playback as well (when playing the video on other computers).
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Note

Video codec is a software tool which can code and decode video files. We recommend to use
one of the following codecs:

Cinepack
Provides maximum compatibility and small files.

Intel Indeo
Provides the best quality/compression rate.

Microsoft YUV
A non-compression (maximum-quality) codec.

Size
The size is determined by the resolution of the connected camera, but can be adjusted by the following
options:

[Original], [1/2 Original], [1/4 Original]
Sizes counted from the applied camera resolution

[NTSC TV], [PAL TV]
Standard TV resolutions

Free Size
an arbitrary [Width] and [Height] in pixels may be defined.

No matter what size is selected, the video always displays the whole scene. If the defined size has dif-
ferent aspect ratio than the live image, the empty space is filled with black.

Maintain aspect ratio of
If the [Free Size] option is selected, the aspect ratio may be defined. One of the width and height di-
mensions are then counted automatically.
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7.13.2. Converting ND2 to AVI
You can easily create an AVI movie from an ND2 document. Run the [File > Save As] command and instead
of saving the file as an ND2, simply select the AVI format in the [Save As Type] pull-down menu. The [Save
As] window expands as follows:

Adjust the AVI file settings and press [Save] to finish. Please see the [File > Save As] command description
for more details.
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7.13.3. Creating AVI from a Sequence of Images
You can convert a sequence of images to AVI by the [File > Sequences > Create AVI] command. After you
invoke the command, the [Create AVI] dialog box appears:

Create an AVI file:

• Select a folder to look in for images and choose the images. To select multiple images, either click on the
first and the last image holding the [Shift] key (continuous group selection) or click individual image names
with the [Ctrl] key down.

• Define the output file name and adjust all the parameters of the output file dimensions and timing. To
select a video codec to be used, de-select the [Use Default Video Compression] option. The default
codec (Intel Indeo) will be used otherwise.

• Click [OK] to confirm the settings. An [AVI Creation Preview] window appears.

• After the sequence is processed, press the [Close] button to finish. The file is saved automatically to the
previously specified location.

See [File > Sequences > Create AVI] description for more details.
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7.13.4. Movie Maker (-LO- option)
[3D Volume View] and [EDF 3D Surface View] (-EDF- option) objects are about be brought to life once
the NIS-Elements AR movie-maker is started. The Movie Maker control window appears after you press the

button located on the document tool bar (Volume View or Surface View must be must be active). The
user is supposed to create a set of key-frames. The rest of the movie will be created by interpolation between
these key frames. This gives the user absolute freedom in how the movie will look like.

Movie Maker Controls

When you start the movie maker, the following bar appears at the bottom of the document view.

1. The [Clapper] button. By this button, the director's mode can be turned ON/OFF. See Directors Mode.

2. Time line. By clicking to the time line you can browse the movie frames. When a key frame is added, a
bold line appears in the time line to indicate its position.

3. [First Frame], [Play], [Last Frame] buttons.

4. [Settings] - by this button, you can define the movie length and the frame rate.

5. [Create Movie]

6. The key frame buttons. The existing key frames may be browsed by pressing the [Previous/Next Key
Frame] buttons. The [Add/Update Key Frame] button inserts a key frame to the current position on
the time line.

7. [Presets] - a predefined rotation can be loaded. When you press the button and select the rotation type,
the existing key frames settings will be overwritten.

8. [Import/Export Key Frames] - this enables you to save and load the key frame settings. A file with the
[*.KEY] extension will be created during the export.

How to Create a Movie

• Run the Movie Maker by the button.

• Adjust the movie settings by the [Settings] button a window appears where the movie duration and frame
rate can be defined.
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• You can use one of the predefined presets or import some previously defined key frames by the [Export/Im-
port] button.

• Either enable or disable the Director's mode by the clapper button. See Directors Mode.

• Go to the beginning of the time line and define the initial zoom, position, rotation or component appearance
of the object. This step is not necessary, but very much recommended. Press the [Add/Update key
frame] button to fix the initial appearance.

• Browse the time line, modify the object position each time, and set key frames by clicking the [Add/Update
key frame] button. Press the [Play Movie] button for a preview.

• When all the key frames are properly set, press the [Create Movie] button. The movie is created and the
AVI file will open in a new document window.

• Save the new file by the standard [File > Save As] command.

Directors Mode

In the directors mode it is not needed to press the [Add key frame] button every time the position of the
object is changed. The director's mode detects all changesmade to the object position and adds a key frame
to the time line whenever such change is detected. A typical work-flow would look like this:

• Turn ON the directors mode by the [Clapper] button. The time line gets highlighted with red color.

• Click to the time line where a certain position of the object shall occur.

• Move the object by mouse or adjust it in some way (zoom, crop, etc.) - at this moment, the key frame will
be added to the time line automatically.

• Click to the time line where another position shall occur, and so on...

The director's mode shall be used when you know precisely how the movie shall look.
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Special Options

A contextual menu appears whenever you right-click on any key frame or between two key frames (a segment)
within the time line.

Set key frame time
Sets the selected key frame position - moves the key frame to this position.

Set as new start of the movie
Sets the selected key frame as the first frame of themovie andmoves all other key frames proportionally.
Key frames prior to the selected one will be deleted.

Set as new end of the movie
Sets the selected key frame as a new end of the movie and moves all other key frames proportionally.
Key frames past the selected one will be deleted.

Copy/Paste key frame
Enables to copy and paste key frames.

Delete key frame
Deletes the selected key frame.

Delete all key frames
Deletes all defined key frames.

Set time segment duration
Sets the segment duration. Positions of all other key frames will be moved proportionally.

Hold/Linear/Spline
Select the type of interpolation to be used between two key frames. Set [Spline] for smooth changes
(motion, lightness etc.)

Interpolation Types

Ease in/out
Easing defines the interpolation rate between two key frames. No easing means constant rate of inter-
polation. Use the [Ease in] option for the first time segment to increase slowly the rate of change. On
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the contrary, the [Ease out] option serves the best at the end of the movie to make the motion slowly
stop. Of course, you can get the benefit of combining them.

Interpolation Rate Types
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7.14. Exporting Results
Some image analysis data and measurement results can be transferred out of NIS-Elements AR so they
could be used further. There is a standard [Export] pull-downmenu in some of the control windows (intensity
profile, histogram, measurement, etc...) which enables the export.

The set of commands of the menu differs according to the type of data (tables or graphs) which can be ex-
ported. Click the arrow button to display the pull-down menu. When you select the destination, the pull down
menu hides and the icon of the selected export type appears on the [Export] button. The export action is
performed after the button is pressed once more.
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Export Destinations

It is possible to export tabular data or a graph:

To MS Excel
Tabular data can be exported to MS Excel. A new XLS sheet opens and the table is copied to it automat-
ically.

To File
Tabular data can be exported to an MS Excel sheet (xls) or a text file (tab delimited txt).

To Clipboard
Data tables and graph images can be exported (copied) to MS Windows clipboard. Then the data or the
image can be inserted into any appropriate application (text editor, spreadsheet processor, graphics
editor) typically by the [Paste] command.

To Report
Tabular data and graph images can be exported to NIS-Elements AR report. If a report is already opened
for editing, the data/graphwill be appended to it. Otherwise, a new report will be created and the exported
data inserted to it.

To Web Browser, To Clipboard as HTML
Some tabular data can be exported as a HTML table. It can be displayed in a default Internet browser
(the [Web Browser] option), or the HTML code can be copied toWindows clipboard - ready to be inserted
to any HTML/text editor.

To Printer
Tabular data can be printed directly. This option opens a standard [Print] dialog window where it is
possible to select a printer and print the data.

Data Export Options

Run the [Edit > Options] command and switch to the [Data export] tab or press the [Settings] button
within the export pull-down menu. There are two tabs available:
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Global Settings Options

Export into Microsoft Excel application
Select this option if you want to export the data to MS Excel application. You can choose if the data will
be exported into currently opened file or a new file will be created. Or you can set to export the data to
a specific file. If this file does not exist, it will be created. Choose the path and name of the file to be
created/opened.

Set the [Start at column] values (column and row indexes). These values mark the first cell in the MS
Excel application which will hold the exported data.

Export text files into folder
Select this item if you prefer to export the data to a text file. Press the [...] button and specify the target
folder and the file name.

Append exported data after previous exports
If you check this item the existing data will not be overwritten by the new data.

Export also column headers if not appending
Include the titles of columns. If the [Append exported data after previous exports] is selected, no
headers will be included in the export.

Active target application after export
If you check this item the exported file is opened in the default application (MS Excel or the default text
editor) automatically.
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Data export Options

You can modify the amount of data included in each export type.

The control windows which contain the Export to file functionality are listed in the top pull-downmenu. Select
the control window of which the export shall be modified.

Export Name
A control window such as [View > Analysis Controls > Annotations and Measurements] stores
information about themeasurement in multiple tables according to themeasurement type (area, length,
etc.). In this column, you can select the table you would like to modify.

Sheet name
In this column you can define an arbitrary name which will be used to name a sheet or a txt file to which
the data will be exported.

Options for:
This section of the window enables you to select the items to be included/excluded from the selected
table during export.
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8. Cameras
A digital camera mounted to a microscope port or a macro-scope stand records images of the observed
scene on a light-sensitive sensor, and transfers them to a computer. NIS-Elements AR supports various
cameras differing from each other in resolution, frame-rate, sensor type, etc. Despite these differences,
controlling different cameras is similar. The following features are included in the [View > Acquisition
Controls > Camera Settings] window depending on a particular camera type.

8.1. Common Settings

Fast (Focus)/Quality (Capture) Formats
Usually, cameras can provide several image resolutions. NIS-Elements AR enables to create two presets
of the resolution settings - [Fast] and [Quality] . The formats then differ in image size, and consequently
in frame rate (number of frames per second - fps). The higher the resolution is, the lower frame rate
can be achieved. Available resolutions depend on the camera type.

Binning
The binningmode provides considerably enhanced camera chip sensitivity by integratingmore elements
(pixels) together. E.g.: [binning x4] integrates the signal from the area of 4x4 chip elements to one
pixel of the resulting image. Smaller resolutions and faster frame rates are achieved using the binning
modes.

Exposure Mode
Exposure mode sets how the Exposure time is calculated. Generally, there are automatic and manual
modes:

• [Auto Exposure] - Calculates an optimal combination of [Exposure] time and [Gain] in order to
achieve optimal exposure. Image quality is the priority, therefore longer exposure times are chosen.
Usually, the auto exposure can be run once by pressing the [Auto Exposure] button, or continuously
by selecting the nearby check box.

• [Manual Exposure] - User selects both [Exposure] time and [Gain] manually.

Exposure
When in [manual exposure]mode, this option controls the exposure time, which is expressed inversely
(1/x second). It is the time of charge accumulation in a camera chip between two adjacent frames.
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Prolonging the exposure time increases the brightness of the image as well as the image quality (the
less gain, the less noise), and decreases frame rate.

Gain
Controls the sensitivity of a camera. Increasing the gain increases brightness of the image, but decreases
quality (themore random noise, themore streaky noise and color unevenness), and increases the frame
rate indirectly by enabling shorter exposure times.

Averaging
Averaging is a commonly used technique of decreasing noise in the image. In this method 2, 4, 8 or 16
consecutive frames are averaged together.

Offset
Sets the brightness of the image. It is a constant additive (positive or negative) changing all pixel values
of the image. With negative offset value the dark image areas become pure black. Considering fluores-
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cence microscopy, an appropriate offset setting can create continuous black background and thus help
to enhance (together with gain or illumination enhancement) the contrast.

Contrast
Affects dynamics of how the luminosity is rendered. There are several modes for different illumination
(contrast) scene situation.

Gamma
The gamma correction maps the intensity of live signal exponentially to the gamma parameter. For
gamma < 1, dark portions of the image are enhanced whereas for gamma > 1, image parts of higher
intensities are enhanced.

AE Compensation
In automatic exposure modes, the compensation affects how optimum exposure settings (Exposure
time and Gain) are calculated. The Compensation value is expressed in Exposure Values (EV). Setting
the compensation to + 1.0 EV makes the image twice brighter (e.g. doubles the Exposure time or Gain).

AE Lock
This option makes the automatic exposure mode to lock the current exposure settings (Exposure time
and Gain).

Sharpness
Some camera settings provide the sharpness control which affects how sharp edges in the image appear.
Too much sharpness leads to oversaturated edges.

Hue
Hue shifts image colors across the rainbow.

Saturation
The amount of saturation determines how colors are rendered. More saturation produces richer colors.
Less saturation makes the colors gray.

White Balance
There are usually Red, Green and Blue Gain properties that control how colors are rendered. It is used
to eliminate a color cast from white areas.

Auto White Balance (AWB)
The AWB button performs an automatic white balancing. It adjusts the red, green, and blue image
components in order to get a neutral white color.
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8.2. Advanced Settings

Separate Channel Settings
Having a color camera, influence of the settings described above on each color channel can be adjusted.
In such case, three edit boxes with the default values set to 1.0 are displayed below the feature setting.
These values determine the influence of the feature on each color channel.

Using Probe

The probe enables you to determine a small image area that serves as the data source area for
LUTs, histogram etc. It also affects the AWB (auto white balance) and the AE (Auto Exposure) features
of the cameras that support it. When the probe functionality is not supported, the AWB and AE algorithms
are computed from the whole image.

Live Acceleration
Would you like to increase the frame rate of the live signal? Move the slider to a desired multiplier. The
system then automatically shortens the exposure time (so the frame rate rises), and the loss of intensity
is compensated by gain (software multiplication).

Target Maximal Intensity
Restricts the maximal image intensity after the auto exposure was applied. The value represents a
percentage of the whole camera dynamic range.

Maximal Exposure
This is a safeguard of the time of the Auto Exposure. For quick exposure, it is convenient not to set this
value too high.

Overillumination Tolerance
Sets how many pixels should be white after the Auto exposure is performed. Use lower values (0.01%)
for very bright (shining) objects (fluorescence). For common bright field, even 1% may be a good value.
Optionally, you can define the absolute number of white pixels.

Use Current ROI
The currently defined region of interest, set by the [Define ROI] command, can be switched ON/OFF
by checking this item.
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8.3. Camera ROI on Live Image
You can specify a camera ROI on a live image by selecting the [DefineROI] command placed in the document
tool bar next to the ROI button. In a window that appears, set the dimensions and the position of the ROI
rectangle. The live image is then restricted to the defined area when the [ROI] button is pressed.
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8.4. Controlling Cameras by Macro
Every camera can be controlled from within a macro by changing its properties. There is a CameraGet_* and
CameraSet_* macro function available for each camera property (e.g. CameraGet_ExposureTime();). The
number of functions (beginning with CameraSet_/Get_) and their actual names depend on the type of
camera(s) you have currently connected to NIS-Elements AR.

CameraGet_
The [CameraGet_...] functions retrieve current values of the properties determined by the function
namepostfix. So theCameraGet_Exposure(int Mode, double *Exposure); function retrieves
the current value of Exposure of the specified Mode.

CameraSet
The [CameraSet_...] functions allows you to adjust camera properties. So the CameraSet_Expos-
ure(int Mode, double *Exposure); function sets a new Exposure value for the specified
Mode.

8.4.1. How to Set Camera Properties
Instead of describing each property function, we will show you a universal way how to handle a camera by
macro:

1) Display the [View > Acquisition Controls > Camera Settings] control window and find the property
you would like to control.

2) Make a change of the property from within the control window. For example, change the exposure
time.

3) Display the [View >Macro Controls > Command History ] window and see the last function which
has been called and its parameters. This is the function you will control the exposure time with.

4) Experiment with the camera control window in order to determine the right parameter values of the
functions to be called within your macro.

Note

See the [Function Reference > Acquire > Camera > Properties] section of the online help. Some
of the most common functions are described there.
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9. Devices
Before you get to work with NIS-Elements AR, all hardware accessories should be connected properly to the
system. In most cases, the following basic procedure is sufficient to connect a device successfully:

• Install NIS-Elements AR, and select the appropriate devices during the installation.

• Connect the device to a PC and switch the device ON.

• Run NIS-Elements AR, and run the [Devices >Manage devices] command to open the Device Manager.

• Use the [Add] button to add the device to NIS-Elements AR.

• Select the device in the devices list and press the [Connect] button.

• Select logical devices to be activated.

• Configure device-specific settings using the [Configure (physical) Device] and the [(logical) Device
Parameters] buttons.

• [Close] the Device Manager.

9.1. Logical Devices
NIS-Elements AR handles hardware accessories using the concept of logical devices. There are some features
of different hardware devices which equal, and therefore can be controlled equally. Such features are called
“logical devices” for purposes of NIS-Elements AR. A typical logical device is [Stage XY]. Differentmicroscopes
can be equipped with different XY motorized stages, although - regarding the user interface - they behave
equally. One physical device (a piece of hardware) can contain one or more logical devices the list of which
appear in the Device Manager after the connection is established.

175

User's Guide



Available Logical Devices

Analyzer
The analyzer is a polarizing filter placed in the optical path between the specimen and the lamp. The
logical device offers two states: ON (inserted) and OFF (extracted).

Aperture
This logical device is used for controlling apertures in the light path. It is used in complex microscopes
rather than as a standalone device. Two parameters can be typically set for aperture devices, the state
(ON/OFF) and aperture size.

Condenser
A condenser is a two-lens combination located next to the light source in the optical path. Its purpose
is to collect light and direct it to the specimen being examined. The corresponding logical device relates
to a changer of different condensers.

Filter
This logical device controls filter changer movements. There can be several filter changers connected
to NIS-Elements AR at a time. Each filter changer needs to be set up - filter types shall be assigned to
positions of the changer:

• Display the filter changer control window ( [Devices > Filters&Shutters] or [Devices >Microscope
Control Pad] ).

• Click the settings button, a window appears.

• Select one of the available positions which the filter will be assigned to.

• Select the filter name from the [Predefined] / [Custom] list of filters.

• Click the [<-Set] button

• The filters can be moved within the already defined positions using the [Up/Down] arrow buttons.
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Note

When browsing the list of filters, details about the currently selected filter are displayed in the
right-most portion of the window.

Light
This logical device is used for controlling the specimen illumination remotely. There is not any standard
dialog box for the light control. Each device handles this logical device via a specially designed user in-
terface - typically containing one button for ON/OFF switching and a slider for intensity regulation.

Light Path
Some microscopes have more than one port where it is possible to attach a light source or a camera.
This logical device can switch the light between these ports.

Microscope
This logical device is used to group standalone logical devices used in microscopes. To control the lo-
gical devices of a microscope from one control window, select the [Devices > Microscope Control
Pad] command.

Nosepiece
This logical device serves for controlling microscope objective changers. There can be three nosepiece
types attached to a microscope:

• [Manual] - it can not be controlled via the [Microscope Control Pad] or the [Nosepiece] control
window.

• [Intelligent] - the current nosepiece position is read by the application, but can not be controlled.

• [Motorized] - such nosepieces can be fully controlled via the [Microscope Control Pad] or the
[Nosepiece] control window.

See Assigning objectives .

ND Filter
A neutral-density filter is a light absorbing filter whose absorption spectrum is moderately flat. It is used
to reduce the light intensity within the optical path. The logical device offers two states: ON (inserted)
and OFF (extracted).

PFS
Perfect Focus System - this logical device corresponds to the PFS physical device available with Nikon
TE2000/TI microscopes.

Shutter
This logical device can control shutters installed in your system. This device is handled via the [Devices
> Filters & Shutters] control window or straight from themicroscope control pad. You can also rename
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the shutter by running a command which appears in the contextual menu in [Filters & Shutters]
control window, [Device Manager] window, or in the device toolbar contextual menu.

Zoom
This logical device is used for controlling the zoom factor. Run the [Devices > Zoom Configuration]
command to adjust the zoom settings.

Stage XY
Stage XY enables the movement of specimen within X and Y axes. The system offers user to control
stage movements and brings some extra functionality.

Stage Z
The Z Drive device enables movement throughout the Z axis direction.

TTL/Analog Input, Output
There are six types of logical devices available when the NI DAQ controller set is installed: TTL Input,
TTL Output, Analog Input, Analog Output, Calibrated Analog Input, Calibrated Analog OutputEach of
these logical devices represents one connection to an external device. The number of connections de-
pends on the actual hardware setup.

Assigning objectives

• To assign an objective (or to change an attached objective assignment) to a position, click the setup
button in the microscope control pad.

• A window appears which enables you to select on of the available objectives to the corresponding position.

• Each objective has its specifications displayed in the table. These specifications are not editable.

Using two independent Z Drive devices

Workstations can be equipped with two independent Z drive systems, one slow (or coarse) and the other
fast (or fine). Typically the first one is used for specimen manipulation in Z axis, the second one for auto-fo-
cusing.

Absolute Z
The current positions of both Z drives (Z1, Z2) and the absolute Z position (sum of Z1 and Z2) are dis-
played in the main status bar. If there is not enough space for all these values, only the [absolute Z]
value is displayed (Z1 and Z2 still appear in a tool-tip). The absolute Z value appears in the Z Series
Setup.

Active Z

The concept of [Active Z] enables user to select the preferred Z drive:

• The active Z drive is used when performing auto-focus.

• The [Devices > Enable Mouse Joystick Z in Live] command applies to the active Z.
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You can select the Active Z device in the [Devices > Mouse Joystick and Auto Focus Z] menu.

Regular Z drive + Piezo Z drive

If you have a regular Z drive and a Piezo Z drive installed, some functionality is added:

• The [Home Piezo] button is added to the [Z Series Setup] window when Piezo Z is selected.

• The [Devices > Keeps Z position and centers Piezo Z] and the [Devices > Move Piezo Z to
Home Position] commands appear in the [Devices] menu

The button and the [Devices > Keeps Z position and centers Piezo Z] command provide corres-
ponding functionality. They move the Piezo Z device to its home position, and compensate this shift by
moving the second Z drive in order to maintain the absolute Z position.
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9.2. Nikon Eclipse 90i/80i Microscope
The 80i/90i (fully armed) Microscope Control Pad consists
of the following portions:

Nosepiece
This portion depends on the type of the connected
nosepiece:

• [Manual] - it remains hidden

• [Intelligent] - it indicates the current nosepiece
position, but can not be controlled.

• [Motorized] - it can be fully controlled.

Lamp
The light path accessories that affects light intensity
can be controlled here. The condenser turret is con-
trolled by selecting the desired condenser from the
pull-down menu.

Z Drive
The Z drive movements are indicated/performed via
the scrollbar. Tolerance (precision) can be set in the
pull-downmenu. The higher the tolerance is, the faster
the Z drive moves, though less precisely.

Filter Block Changer
The standard motorized filter changers control.
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9.3. Nikon AZ100 Microscope
When [AZ100] is connected to NIS-Elements AR, the
manual remote control gets disabled automatically. The
AZ100 Microscope Control Pad consists of the following
portions:

Objectives
The objectives portion of the pad indicates the
nosepiece status: the currently selected objective and
objectives magnification. The objective changer can
not be controlled by NIS-Elements AR .

Zoom
Zoom magnification can be changed by moving the
scroll bar. The current zoom factor is indicated above.
Since the zoom device is a part of the microscope
equipment, concerning optical configurations, its
settings are automatically treated as an inseparable
part of [microscope settings] .

Condenser
The green button indicates the current condenser
lenses position (Low/High). The condenser cannot be
controlled.

Z Drive
The Z drive can be controlled via the microscope control pad in the following way:

• The [up/down arrows] move the Z drive by a defined [Step] .

• The current position can bememorized by pressing the [Set] button. The position value will be written
to the pull-down menu.

• To move the Z drive to a memorized position, select the desired value from the pull-down menu and
press the [Go] button.

• The current position is indicated below the [Step] edit box.

FilterBlocks
The currently selected filter of the four available filter positions is indicated in the Filter Blocks portion
of the pad. The filter changer cannot be controlled by NIS-Elements AR . Filters assignment may be
changed after pressing the [...] button.
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9.4. Nikon Eclipse LV Series Microscope
The LV (fully armed) Microscope Control Pad consists of
the following portions:

Nosepiece
The motorized objective changer can be controlled
via this portion of the window.

Accessories
Intensity of episcopic and diascopic light sources can
be controlled.

Z Drive
The motorized Z drive is controllable too. Clicking the
arrow buttons moves Z drive by the step defined in
the pull-down menu. The [Escape] button moves the
objectives out of the stage reach. The bottommost
position (lower limit) of the Z drive can be set using
the [Set Limit] button. The [Clear Limit] button dis-
cards the setting.

Please make sure to set [Lower limit] before using
themicroscope. Otherwise, the objective can accident-
ally hit the stage while the motorized Z drive moves.

Filter Blocks
There are 4 available positions in the changer. The
first two have fixed filters for bright field (BF) and dark
field (DF) microscopy. The other two are available for
any filters to be inserted.
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9.5. Nikon Eclipse L200 Microscope
The L200/L300 Microscope Control Pad consists of the
following portions:

Nosepiece
The motorized objective changer can be controlled
via this portion of the window. If a move from position
1 to position 6 is ordered, a warning appears. This
behavior shall prevent the high magnification object-
ives to strike the XY stage.

Light
A halogen lamp or the [Nikon Intensilight] illumina-
tion device can be attached to the EPI port of the mi-
croscope. Both lights can be controlled from here (if
selected in the Light Control pull-down menu). If two
halogen lamps are attached, the light control works
as the EPI/DIA switcher.

Aperture Stop
These two arrows control the EPI aperture stop equally to the buttons on the microscope body.

Light Control
You can select from where the lamps will be controlled:

• NIS-Elements AR - from the Control Pad

• [ Microscope] - from the microscope body
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9.6. Nikon Eclipse MA200 Microscope
TheMA200 InvertedMetallurgical Microscope Control Pad
consists of the following portions:

Nosepiece
The motorized objective changer can be controlled
via this portion of the window. If a move from position
1 to position 5 is ordered a warning appears. This
behavior shall prevent the high magnification object-
ives to strike the XY stage.

Light
A halogen lamp or the [Nikon Intensilight] illumina-
tion device can be attached to the microscope and
controlled from here. If the halogen lamp is attached
to the microscope, internal (manual) or external (via
NIS-Elements AR) control can be selected on the back
of the microscope body.

Shutter
The shutter is a part of the Intensilight device and can be controlled from here.

Intermediate Magnification
This portion of the pad indicates the current state of the intermediate magnification device. There are
three predefined magnifications (1x, 1,5x, 2x).
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9.7. Nikon MM 400/800 Microscopes
A measuring microscope connected to NIS-Elements AR provides two logical devices:

Nosepiece
Two types of nosepiece can be attached to the microscope:

• [Manual] - cannot communicate with the computer. Each time you switch the objectives, you should
also select a position in the Nosepiece control window accordingly.

• [Intelligent] - cannot be controlled by the system, but when you change the objective manually, it
indicates the change in the Nosepiece control window automatically.

After adding the MM microscope to the system via Device Manager, the [Nosepiece] logical device
becomes available. Display its control window by the [View > Acquisition Controls > Nosepiece]
command. The type of the nosepiece must by defined via the hardware control pad in order to be recog-
nized by NIS-Elements AR

Z Drive
The Measuring Microscopes Z drive may be moved using the [View > Acquisition Controls > XYZ
Navigation] control window.
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9.8. Nikon TE2000 Microscope
The TE2000 (fully armed)Microscope Control Pad consists
of the following portions:

Nosepiece
The motorized objective changer can be controlled
via this portion of the window.

Light
Complete light path accessories can be controlled
here. Switch the light between ports as needed.

Condenser
The condenser turret is controlled by selecting the
desired condenser from a pull-down menu.

Z Drive
The Z drive position is indicated, or can be controlled
via a scrollbar.

PFS
The functionality of the PFS-section of the control pad
corresponds to the hardware controller.

Filter Changers
Standard motorized filter changer controls. You can
select whether filter colors or position numbers are
displayed on the buttons.
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9.9. Nikon TI Microscope
The TI (fully armed) Microscope Control Pad consists of
the following portions:

Nosepiece
The nosepiece can be controlled here. The objective
settings are being shared between NIS-Elements AR

and the microscope RCP. Press to display the
nosepiece settings window.

Light Path
The light path control buttons correspond to the but-
tons placed on the microscope body.

PFS
This optional accessory can be controlled via the pad.
The offset value can be put straight in the edit box.
When you are about to turn the PFS ON, make sure
the [Focus] indicator shines. It indicates that the PFS
is ready to get to the defined offset position. The
[Memory] and [Recall] buttons equal the buttons
on the microscope body.

Vast shift of the Z drive can cause that PFS will not
be able to refocus. That is when the [Focus] indicator
stops shining.

Z Drive
Movements of the integrated Z drive are performed
by the up/down arrows. Accuracy can be set in the
pull-down menu on the right. The Accuracy setting
affects the Z drive speed slightly.

Lamp
Three types of illumination devices can be attached:
Diascopic lamp, Intensilight fiber illuminator, TIRF illu-
minator. All these devices are controllable via the
control pad.

[TIRF] - A shutter can be assigned to close every time
the TIRF position is being changed. To do so, right-
click the TIRF logical device within the [Device Man-
ager] window and select the shutter type from the
context menu. You can set the set TIRF control sens-
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itivity (coarse, fine, or extra fine) in the Microscope Control Pad. TIRF can be controlled by mouse wheel
or joystick X axis (or both.

Shutters
Register the correct shutter types in the RCP. Then, the shutters can be controlled by NIS-Elements AR
.

Piezo Z
An optional piezo stage is controlled equally to the Z Drive device. The piezo Z component should be
registered via RCP, and direct USB cable must be used between PC and the microscope body (not the
HUB connection).

Filters
The standard motorized filter changer control. The [Analyzer] button appears, when the [ANALYZER]
filter type is assigned to one position of the turret. Press the [IN/OUT] button to insert/extract the
analyzer.

Condenser
The condenser turret is controlled by selecting the desired condenser from the pull-down menu.

Recipe (-AR- option), (-BR- option)
TI recipe is a special feature provided by the HUB-A. It provides hardware acceleration of an ND capturing
experiment. Mark the check box to enable the acceleration and select the port to which the camera is
connected. See below.

9.9.1. Using TI Recipe
To enable the TI Recipe functionality, the following hardware configuration is necessary:

Hardware requirements

• [HUB-A]

• [Andor DU-897] camera connected to the DSC1 or DSC2 port of the HUB-A.

• A shutter device (or two) connected to HUB-A. [Nikon Intensilight] and [Sutter Lambda SC] devices
are supported.
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When connected correctly, the [TI Recipe] check box becomes available within the ND experiment window.

• Define the ND experiment.

• Select the [Enable Ti Recipe] check box in the [Applications > ND > Define/Run Experiment (ND)
(-6D- option) ] command window.

• Click the [Upload Ti Recipe] button to upload the experiment settings to HUB-A.

• Run the acquisition.

When the acquisition is started, the experiment settings are sent to HUB-A where they are converted to a
set of hardware instructions. The acquisition is then controlled by these instructions instead of being controlled
by the software.

There are the following limitations of the experiment complexity:

• Maximum of 100 XY positions (multi-point dimension) can be handled.

• Maximum of 9 different channels can be handled.

• The total number of HUB-A instructions (after conversion from the experiment definition) must not exceed
1000.
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10. Additional Modules

10.1. Database
This chapter will give you an overview of what the capabilities of the database module are.

NIS-Elements AR supports MS Access, MS SQL, and Oracle databases. The capabilities of the database
module are following:

• The system can create and control MS Access databases (*.MDB), the images are stored on hard disk,
only links to them and other data are stored in the database file.

• The system can connect to and control a running MS SQL or Oracle SQL server database, the images are
stored on the server machine within the database. This concept requires a standalone SQL system and
is recommended when working with large amounts of data. Administering and back-ups are handled by
the SQL server.

Note

An *.INI file must be created by the [sql_util.exe] tool placed in the installation directory (this is
done by the administrator during installation). Such INI file provides the connection between
your PC and the remote SQL database. Whenever we talk about the MDB file in this manual,
the same applies to the INI file accordingly.

After you install the Database module, the [Database] menu appears in the main tool bar.

10.1.1. New Database
Before you can connect to a new database the structure of tables and fields, or at least the protection level
shall be set:

1. Run [Database > New Database (-DB- option) ] .

2. Select the database engine and locate the connection file (*.MDB to be created, or *.INI file created by
the sql_util.exe). Click [Next] .

3. Select one of the database templates. Each template consists of several predefined tables. If you choose
[Blank] , no tables will be created (later you will have to use the [Database > New Table (-DB- option)
] command). Click [Next] .

4. Select the default protection of the database. The user accounts can be based on MSWindows accounts,
or arbitrary number of database user accounts protected by password can be created. Or, the database
can be fully accessible for all users - if the [Not Protected] option is selected. Click [Finish] .

5. The database connection will be automatically created and connected. You can browse the database with
the [Organizer] .
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10.1.2. New Connection
If there is an existing database created by NIS-Elements AR, you can connect to it via the [Database > New
Connection (-DB- option) ] command:

1. Run [Database > New Connection (-DB- option) ] . A window appears.

2. Select the correct database engine and locate the corresponding connection file (MDB or INI).

3. Confirm the action with [OK] .

Connections to databases can be managed via the [Database > Manage Connections (-DB- option) ]
command.

10.1.3. Database Tables
A new table can be added to an existing database. Every database must contain at least one table. If you
have created a blank database or you would like to add a table to any of the connected databases, do as
follows.

1. Run [Database > New Table (-DB- option) ] . A window appears.

2. Select one of the connected databases to which the table will be added.

3. Select one of the table templates. Table templates can be imported from the other connected databases.
If you choose [Blank] , you will have to create the table structure from scratch (in the next step). Click
[Next] .

4. Define the field properties in the window that appears.

5. [Finish] the table creation.

10.1.4. User Permissions
Database access rights can be set for individual users. As we mentioned above, there are two types of pro-
tection:

Password protection
Any number of database user accounts can be created. Then you can connect to a database by the
user name and password.

Windows account protection
User permissions to databases can be set for different MS Windows users. The access to a database
is then granted if only the user is currently logged in Windows.

Both protection types can be combined in one database. To manage the user accounts and permissions of
a connected database:

Note

You have to be connected to the database under an account with sufficient user rights.
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1. Run [Database > User Accounts and Permissions (-DB- option) ] . A window appears.

2. Select the database of your interest. All user accounts of the database will appear in the list below.

3. Create new or select an existing user account.

4. Use the buttons on the right to manage the account properties, duplicate it (along with the permissions
settings), change the password, modify the permissions ([Change properties] ), or even delete it.

10.1.5. Database Backup
If you run one of the supported SQL server databases, it is a task for the database administrator to make
backups (or it is usually configured to make the backups automatically). However, if you utilize theMS Access
database engine, the NIS-Elements AR backup scheduler shall be used.

The capability to backup the database is essential for serious work. The Database Backup Scheduler enables
to backup the MS Access database automatically once in a precisely specified time interval, so you do not
have to be afraid to loose any data. The Database Scheduler uses the standard Windows Scheduled Tasks
tool (Start > Control Panel > Scheduled Tasks). Once you schedule a backup, there is only one condition to
perform it successfully: The computer must be turned ON at the scheduled time. Configure the backup via
the [Database > Schedule Database Backup (-DB- option) ] command.
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10.2. Extended Depth of Focus
The EDF module allows you to combine existing Z-stack images into one focused image picking the focused
regions from each frame and merging them together.

When you start NIS-Elements AR with the EDF module installed, the following items appear in the [Applica-
tions] menu:

• [Applications > EDF > Open File Sequence (-EDF- option) ]

• [Applications > EDF > Align Sequence (-EDF- option) ]

• [Applications > EDF > Create Focused Image (-EDF- option) ]

• [Applications > EDF > Edit Area in Focused Image (-EDF- option) ]

• [Applications > EDF > Edit Background (-EDF- option) ]

• [Applications > EDF > Real Time EDF (-EDF- option) ]

• [Applications > EDF > Real Time EDF Manually (-EDF- option) ]

Open (or acquire) an ND2 document that includes the Z dimension. If you use the [Applications > EDF >
Open File Sequence (-EDF- option) ] command to get the Z stack of images, a newNDdocument is created
automatically.

10.2.1. Align Sequence
Small shifts of the images can occur as a result of hardware inaccuracies during the Z series acquisition. To
get reliable results out of the EDF module, the sequence that is to be processed should be aligned first. Use
the [Applications > EDF > Align Sequence (-EDF- option) ] command to automatically correct possible
shifts.

10.2.2. Create the focused image
When the method is selected and the sequence is aligned, the only thing to do is to run the [Applications
>EDF>Create Focused Image (-EDF- option) ] command. The focused imagewill be created and appended
to the ND2 document.

10.2.3. View the result

After the focused image is created, all buttons of the EDF tool bar (located within the document tool bar)
become enabled. There are three ways to observe the resulting focused image, as:

194

NIS-Elements AR



• A common Color/Gray image

• An anaglyph - to be viewed using 3D glasses.

• A 3D model, utilizing so called Surface View.

This button displays the focused image.

Creating anaglyph

Using this button, you can create a three-dimensional stereo image (anaglyph). This image shall be ob-
served with special glasses having red and green or blue filters which provides the 3D impression.
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Exploring the surface view

This button runs the built in surface viewer. The surface viewer displays the surface of a captured object
three-dimensionally. You can rotate the view by mouse or shift it by right-mouse. The mouse wheel serves
for zooming.

Special Options

Default View
Displays the object in default rotation and zoom.

Z-zoom
Adjusts the sequence height for more credible look.

Top/Bottom First
Enables to set whether the first frame in the sequence is the lowest or the highest one.

Select background Color
Enables to choose color of the background.

Show Crop Plane
Enables you to crop virtually cut the surface by a plane. Press [Ctrl] to display the cropping plane and
the axis of rotation. Hold the Ctrl key down and drag the cropping plane or the axis of rotation with left
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mouse button to a new position. Press [Ctrl] and drag the plane by right mouse button to rotate the
cropping plane.

Toggle Scene Lighting
Switches on/off the lighting of surface view.

Export to VRML
Exports the surface to VRML (Virtual reality modeling language). Two files will be saved. One that contains
the 3D information (WRL) and the other is a 2D texture (JPG). Mind, that both files must be distributed
(e.g. placed on the web) together! To view files in VRML format some VRML viewer is needed. The
viewer is a plugin to your web browser. There are several viewers available for free:

• [Cosmo Player] - http://ovrt.nist.gov/cosmo [http://ovrt.nist.gov/cosmo]

• [Cortona] - http://www.parallelgraphics.com [http://www.parallelgraphics.com]

Movie Maker
Runs the Movie Maker. See [Movie Maker (-LO- option) ].

10.2.4. Edit Area in Focused Image
This advanced option enables you to draw an area inside the image and select the Z slice to be used in the
resulting focused image.

• Display the focused image.

• Select the [Applications > EDF > Edit Area in Focused Image (-EDF- option) ] command. The cursor
changes.

• Draw an area inside the focused image which should be affected. Finish drawing by right-click.

Note

The selection can be inverted by pressing [G].

• Use the mouse wheel or arrow keys to browse Z slices within the selected area.

• Finish the procedure by right-click or [Enter] .

10.2.5. Real Time EDF
The [Applications > EDF > Real Time EDF (-EDF- option) ] command is integrating the whole functionality
of EDF. It captures a Z-sequence, aligns the images (optionally), and creates the focused image. When the
[Applications > EDF > Real Time EDF (-EDF- option) ] command is invoked, the [Capture Z Series]
window appears with the [Align images] check box added. There you can set whether to align the images
or not.

If the [Applications > EDF > Real Time EDF Manually (-EDF- option) ] command is used, not requiring
to posses a motorized Z-drive, the [Acquire > Capture Z Series > Capture Manually] window appears
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with the [Align images] check box added. It behaves the same as the [Real Time EDF] procedure except
for the manual way of capturing the Z sequence.

See [Z-series Acquisition].
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10.3. Deconvolution (-LO- option)
The imperfection of amicroscope optical path causes convolution of the original image signal. The convolution
makes the resulting image blurry. Deconvolution is a mathematical algorithm for repairing the blurred parts
of the image. Every optical path can be described by a so called “point spread function (PSF)” which specifies
how a single point of the image will look like when captured by a camera (after convolution). The PSF is
defined by the following parameters:

• Numerical aperture of the objective

• Refractive Index of the immersion medium used

• Microscope modality

• Pinhole size (confocal microscopes)

• Objective magnification (confocal microscopes)

• Objective calibration

• Z-step

• Spherical aberration

• Emission wavelength

The better we know the PSF parameters, the better the de-convolution results will be. The best way to know
the PSF is to the image of a nano-bead and use it to represent the PSF shape.

Note

The background value of the PSF (nano-bead) image must be 0 in order for the deconvolution al-
gorithms to work correctly.

There are the following deconvolution methods available in the deconvolution module all of which can be
applied to either 2D or 3D (including Z-dimension) image documents:

10.3.1. Deconvolution (Standard)
It is assumed that the input PSF parameters are known accurately. Stable, widely used and well known Lucy-
Richardson algorithm is used in this method. The problem which we try to solve can be described by the
following equation:

C = A * B +N

We know the captured image (C) and the PSF (B). We look for the true image (A) and we know there it is
some additional noise (N) present. The [*] operator stands for convolution. So the equation can be rewritten
as:
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Lucy-Richarson (LR) algorithm belongs to the class of so-called Expectation Maximization(EM) algorithms
where we assume the noise(N) has a Poisson distribution. We don't need any other characteristics of N. This
algorithm estimates A from given B and C iteratively. The algorithm always converges to the result but not
so quickly. Because of this, we need to let the algorithm do at least 10 iterations. The number of iterations
can be set within the dialog window.

Resources

• http://www.adass.org/adass/proceedings/adass97/prukschm.html

• http://citeseerx.ist.psu.edu/viewdoc/summary?doi=10.1.1.55.3469

10.3.2. Blind Deconvolution
This method uses the accelerated “Iterative Blind Deconvolution (IBD)” algorithm, that is widely know in the
academic world. It is called “blind” because PSF is not known exactly. However, at least rough estimation
of the PSF parameters is needed. The algorithm improves the PSF/source image estimations iteratively
during the deconvolution process. The problem can be described by the following equation

C = A * B +N

We know the captured image (C), and we look for the true image (A), PSF (B) and additional noise (N). The
“*” operator stands for convolution. The algorithm then works like this:

• It takes the first estimation of B (B1 - from given parameters) and a spectral characteristic of noise (N1)
computed from C and estimates the true image (A1).

C = A1 * B1+ N1

• In the second step, it uses the C, A1, and N1 values to re-estimate the PSF(B2)

C = A1 * B2+ N1

In other words this is a sequence of standard deconvolution operations where we reestimate - for odd steps:
An from C, An-1; for even steps: An from C, Bn.

This re-estimations continue until the defined number of iterations is reached or until the estimated values
stop changing. The quality of results of the blind deconvolution depends on the number of iterations. The
determination of this number depends on visual inspection of the resulting image.

Resources

• http://www.opticsinfobase.org/abstract.cfm?URI=ol-13-7-547

• http://portal.acm.org/citation.cfm?id=1132228
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10.3.3. Fast (Wiener) Deconvolution
It is assumed that the input PSF parameters are known accurately. Compared to the two previous iterative
methods, this algorithm takes a fraction of the computing time. The Wiener filter gives us explicit solution
of the following equation:

C = A * B + N

If we know spectral characteristic of original image(A) and additive noise(N). B means the PSF and C is ob-
served image.

The result is reached by direct division in Fourier spectrum using theWiener inverse filter that can be obtained
as:

where FBInv is a fourier transform of inverse filter, FB* is a complex conjugate of fourier transform of PSF,
FB is fourier transform of PSF, PSN is power spectrum of noise, PSA is power spectrum of original image (can
be substituted by power spectrum of observed image).

When we obtain FBInv the reconstructed image can be obtained as follows:

A' = C*BInv

Resources

• http://en.wikipedia.org/wiki/Wiener_deconvolution
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10.4. High Dynamic Range (-LO- option)
The High Dynamic Range module brings the functionality of creating HDR images within NIS-Elements AR.
The following ways to create a HDR image are available:

Automatic capture
Call the [Applications > HDR > Capture Reflection Free Image (HDR) (-LO- option) ] command
and the HDR image will be captured using computer-estimated settings

Capture
When the [Applications > HDR > Capture HDR Image (HDR) (-LO- option) ] command is called, you
will be asked to adjust the HDR acquisition settings such as number of exposures, exposure time range,
camera settings, etc.

Create from files
If a sequence of images which were captured using different exposure times is available, the [Applica-
tions > HDR > Create HDR Image (HDR) (-LO- option) ] command can load the images and merge
them into a HDR image.

Create from an ND file
Similarly to the situation when the HDR file is created from a sequence of images, it can be as well
created from the frames of on ND2 document. Just run the [Applications > HDR > Create HDR from
ND (HDR) (-LO- option) ] command.

A shining bulb captured with HDR
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HDR module background

The HDR module is based on the image fusion technique which considers the edge response, the “well ex-
posed” measure and the “well saturated” measure. The fusion works locally. That means the measures of
quality are computed for every single pixel from its neighborhood over the whole picture stack. If we simplify
the fusion process, we can say that pixels with the same coordinates are compared throughout the stack of
images and the one with the highest quality measure is chosen to be used in the resulting image.
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10.5. Deconvolution Module (legacy)
The imperfection of amicroscope optical path causes convolution of the original image signal. The convolution
makes the resulting image blurry. Deconvolution is a mathematical algorithm for repairing the blurred parts
of the image. Some characteristics of the optical path (objective) shall be known in order for the deconvolution
module to work properly. The algorithm used is “constrained iterative - maximum likelihood estimation al-
gorithm” (the actual name of the algorithm is “Lucy-Richardson”).

Get a Z sequence of images

Open or acquire an ND2 file containing the Z dimension.

Deconvolve the Z Stack image

Run the [Deconvolution > Deconvolve Z Series] command and set the deconvolution parameters:

• Select your microscopy [Modality] , wide-field or confocal.

• Fill-in the [numerical aperture] (NA) value of the objective used.

• Fill-in the [refraction index] of the immersion medium used. There are some values predefined in the
drop-down menu (air, water, immersion oil, glycerin).

• Fill-in the calibration field! Mind that the deconvolution doesn't work on uncalibrated sequences.

• Pick the channels to deconvolve in the [Channels] field.

• Fill-in the emission wavelengths ([EmW]) of the channels. These values don't have to be accurate because
they affect the result only slightly.

• Fill-in the [ Z-Step] distance between the slices of your sequence.

Note

It is important to fill the same value that was used during the Z Series acquisition. The deconvo-
lution will not work properly without a reasonable Z-Step value. When you are about to capture
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a Z sequence, you should set the Z-step value to [Suggested step size] or smaller in order to get
enough detail for the deconvolution algorithm to work fine.

• Press the [Deconvolve] button.
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10.6. AutoQuant Blind Deconvolution Module
The imperfection of amicroscope optical path causes convolution of the original image signal. The convolution
makes the resulting image blurry. Deconvolution is a mathematical algorithm for repairing the blurred parts
of the image. Some characteristics of the optical path (objective) shall be known in order for the deconvolution
module to work properly.

Get a Z sequence of images

Open or acquire an ND2 file containing the Z dimension.
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Deconvolve the Z Stack image

Run the [Deconvolution > AutoQuant Modules > Deconvolution (-DEC- option) ] command and set
the deconvolution parameters. These values which give information about the microscope settings are
usually retrieved from the captured document (except [Modality]). However, they can be modified by user.

Microscopy Settings

Modality

• widefield fluorescence

• transmitted-light bright field

• laser scanning confocal
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• spinning disk confocal

• multi-photon fluorescence

Numerical Aperture
Fill-in the [NA] value of the objective used.

Refraction index
Fill-in the [refraction index] of the immersion medium used. There are some values predefined in the
nearby pull-down menu (air, water, immersion oil, glycerin).

Calibration
Fill-in the [Calibration] field. Mind that deconvolution doesn't work on uncalibrated sequences .

Z-Step
Fill-in the [Z-Step] distance between the slices of your sequence.

Channels

Pick the channels to be processed by selecting check boxes within the table of image channels. The channel
name, emission wavelength, and spherical aberration are also retrieved from the document or can be
modified by user.

EmW
These values don't have to be accurate because they affect the result only slightly. To modify EmW,
select the channel to which you are setting the emission wavelength, and fill the new EmW value inside
the [Emission wavelength] field.

Spherical Aberration
To modify the spherical aberration setting, select the channel to modify, and move the slider left/right.
The button above the slider resets the [SA] value.

Deconvolution Settings

Number of iterations
Specify how many times you would like to perform the deconvolution algorithm.

Noise level
Select the level of noise present in the images (low, medium, high)

Faster processing/ Reduced resolution
Resolution of the result can be reduced on behalf of the processing speed (the resolution will be reduced
temporarily during the processing. Afterwards, the original resolution will be renewed).
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10.7. AutoQuant Real-Time 2D Deconvolution Module
The imperfection of amicroscope optical path causes convolution of the original image signal. The convolution
makes the resulting image blurry. The Real-Time Deconvolution module algorithm enables high speed pro-
cessing and therefore is very suitable for use on Live signal from cameras. Real-time deconvolution can be
applied to the Live image continuously or just at capture-time. It can be also used for processing saved images.

When you start NIS-Elements AR with the 2D Real-Time Deconvolution module installed, the [RTDeconv]
section appears in the [Applications]menu with the [Deconvolution > RT Deconv > Show RT Deconvo-
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lution Setup (Dec) (-DEC- option) ] and the [Deconvolution > RT Deconv > Enhanced Current Image
(Dec) (-DEC- option) ] commands. Click the first command to display the following control window.

Use 2D Real-Time deconvolution
This option switches on/off the deconvolution on Live image. When a static document is opened, the
Apply button appears instead of this option.

Numerical aperture
NA of the objective lens. This value is written on the objective itself.

Refraction index
Refraction index of the lens immersionmedium (typically 1.00 for air, 1.33 for water, 1.51 for immersion
oil, 1.61 for glycerin).

Emission wavelength
Emission wavelength of the fluorescent specimen in nm. Use 520nm if unsure.

Specimen thickness
Describes how thick the is the specimen being imaged. The value is typically between 1 and 5. Use 1
for optically flat mono-layers, and 5+ for thicker specimens.

The [Enhancing] portion settings affect the noise amplification vs. image smoothness. The [Default] setting
is suitable for low-noise images. Press the [Smoother] button to decrease the image noise and the
[Sharper] button to sharpen the image (but allow some noise).
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Region of Interest (ROI)

Region of interest specifies the part of the image where the deconvolution will be performed. Reducing the
area for the deconvolution will increase its speed. Check the [Entire Image] option to deconvolve the entire
image. If this option is not selected, you can define the [Position] of the top-left corner of the ROI and its
size in pixels. Or, the ROI can be drawn to the image by mouse. To do so, press the [Define...] button, draw
the rectangle to the image and finish the definition by right-click.

“Not calibrated!”

It is necessary to have the image calibrated in order for the deconvolution module to work. If you see this
message, you should calibrate the image or the objective you use.
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10.8. Metalo - Grain Size Analysis Module
After themodule installation, a new item called [Metallography] appears in the [Applications]menu. Select
the [Grain Size] command to display the grain size measurement layout.

10.8.1. Features of the Grain Size Analysis Module:

• Measurement of single-phase structures (e.g. Austenite, Aluminium).

• Measurement of two-phase structures (e.g. Ferrite-Austenite, Ferrite-Pearlite).

• Planimetric, Linear, Circular, and Abrams measurement methods.

• Customization of the predefined measurement procedures.

• Support of ASTM and JIS standards (ASTM E112-96, ASTM E1382-97, JISG0551).

• Easy data export.

10.8.2. Quick Guide

• Open/acquire the image to analyze.

• Set the structure type and the detection procedure parameters within the [Detection] tab.

• Set the measurement procedure parameters within the [Measurement] tab.

• Run the [Measure > Measure] command.

• View themeasured data within the [Data] tab and export it to one of the available outputs via the [Export]
button. See [Exporting Results].

The analysis can be performed even on two or more images sequentially. After defining all the parameters,
run the [Measure > Measure Sequence] command.
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10.9. Metalo - Cast Iron Analysis Module
After themodule installation, a new item called [Metallography] appears in the [Applications]menu. Select
the [Cast Iron] command to display the cast iron measurement layout.

10.9.1. Features of the Cast Iron Analysis Module:

• Graphite classification according to ISO/ASTM/JIS standards (ISO 945, ASTM A247-06, JIS G5502).

• Ferrite/pearlite ratio measurement.

• Customization of the predefined measurement procedures.

• Easy data export.

10.9.2. Quick Guide

• Open/acquire the image to analyze.

• Set the detection procedure parameters within the [Detection] tab.

• Set the measurement procedure parameters within the [Measurement] tab.

• Run the [Measure > Measure] command.

• View the measured data within the [Data] tab and export it to one of the available outputs via the Export
button. See [Exporting Results] ].

Note

The analysis can be performed even on two or more images sequentially. After defining all the
parameters, run the [Measure > Measure Sequence] command.
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10.10. Calcium and FRET module
Installing the [Calcium and FRET] module adds several tools to the system:

• A control window suited for capturing FRET images.

• Automated FRET calibration algorithm.

• The [Create FRET Image] window for “passive” creation of FRET images from files.

• Calcium ion concentration measurement ability.

What is FRET?

• A non-radiative transfer of energy from a donor molecule to an acceptor molecule….

• Förster/Fluorescence Resonance Energy Transfer

• Fluorescence emission from an acceptor molecule due to non radiative energy transfer when a donor
molecule was excited.

Conditions for FRET

• Donor’s emission must overlap acceptor’s excitation

• Donor and acceptor molecules must be <100 Å apart.

• Donor and acceptor molecules’ dipole orientation must be parallel.

See also ???.

10.10.1. Capturing FRET image, FRET calibration
Run the [Applications > FRET > Capture FRET Image] command to display themain FRET control window.
Select the appropriate settings and capture the FRET image by the [Capture FRET] button.
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Hardware Setup

The FRET control window consists of several sections. In this section, optical configurations which will be
used during the acquisition should be assigned to FRET channels.

Optical Configuration
In this pull-down menu, select an optical configuration that contains [Camera settings] which shall
be used during the FRET image acquisition. If [None] is selected, the current camera settings will be
used.

Channels
The FRET image can contain 2-4 channels. Here you can assign an optical configuration to each of
them. It is recommended that the optical configuration contains only the filter changer settings.

Note

If the Dual View device is available, it can be used for channel splitting. Then, only one optical
configuration for each excitation wavelength will be used. The Dual View device splits the
emitted light to two beams filtering different wavelengths, and each of them is captured by
only a half of the camera chip.

Load/Save
The channels settings may be saved to the system by the [Save] button. Once saved under some user
defined name, this name appears in the [Load] pull-down menu ready to be loaded. The settings can
also be loaded from an external FRET image.
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FRET Calibration

Separate images of the D-labelled and the A-labelled samples must be acquired in order to calibrate the
FRET method correctly.

• Insert the D-labelled sample. Press the [Capture Donor Only Sample] button.

• A new document will be captured and named "Donor".

• Insert the A-labelled sample. Pres the [Capture Acceptor Only Sample] button.

• A new document will be captured and named "Acceptor".

• Press the [Calibrate] button to display the calibration dialog.

• Select the “Donor” image and the “Acceptor” image in the appropriate pull-down menus.

• The [Define ROI] and the [Define Background ROI] buttons enable to distinguish the foreground/back-
ground parts of the images.

• Draw the background/foreground ROIs.

• Confirm the calibration by [OK].

Note

Any image file can be used for the calibration. The pull down menu displays the currently opened
images. Other images can be reached via the [Browse] button. If a non-FRET image is used, a
window appears where you should map the image channels to FRET channels and select the FRET
method.
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10.10.2. FRET Method
In this section, select one of the two available FRET methods.

Sentisized Emission

Specified bleed through

The Xx FRET members are average intensities of assigned FRET image components.

The Xx DONOR/ACCEPTOR coefficients are average intensities of the donor/acceptor-only images.

The FRETEFFICIENCY is calculated by the following formula:

EFFICIENCY [%] = (FRETCORRECTED / DdFRET ) * 100

FRET coefficients

There can be 2 or 4 coefficients used according to the method. Their values are results of the calibration. If
the calibration was not performed, you can put the coefficients in by hand. The coefficients settings can be
saved/loaded.

• Donor in FRET (CoB) = DaDONOR / DdDONOR

• Acceptor in Donor = AaDONOR / DdDONOR

• Acceptor in FRET (CoA) = DaACCEPTOR / AaACCEPTOR

• Donor in Acceptor = DdACCEPTOR / AaACCEPTOR

10.10.3. Creating FRET image
The FRET image can be created from images saved on harddisk too. Run the [Applications > FRET > Create
FRET Image] command. A window appears. The FRET image creation principles are the same as if capturing
the FRET image except that you provide the module with mono images from harddisk instead of capturing
them via a camera.

• Select a mono image from the pull-down menus for each FRET channel. Their previews appear.
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• Select a method, calibrate the module, modify the coefficients (similarly as if capturing the FRET image).
Confirm the settings with [OK] .

• A new FRET document is created and opened within the application screen.

10.10.4. [Ca 2+] Ion Concentration Measurement
The [Calciumand FRET]module providesmethods for an efficient calcium ion concentrationmeasurement.

See also ???.

Ratio Experiment Commons

• Usually, [Fura-2] ratiometric fluorescent dye which binds to free intracellular calcium is used.

• Fura-2 is excited at 340 nm and 380nm

• Ratio of Emission of 340 and 380 correlated to the amount of intracellular calcium

• The ratio of the emissions at 340 and 380 wavelengths is directly correlated to the amount of intracellular
calcium

• Why Use a Ratio? Because it is not as sensitive to changes in:

• Dye concentration

• Auto fluorescent background

• Focus Drift

• Ambient Lamp

Procedure

1) Define ROIs for the Ca 2+ measurement.
2) Perform Time Measurement either during an ND2 experiment or on an existing ND2 file.
3) Turn Ratio View ON ([View > Ratio View]).
4) Go to the Time Measurement window and display the ratio graph in the [Multi Dyes] mode.
5) Press the [Define Calcium Calibration] button within the time measurement control window

to pick the calibration values from the graph.
6) A wizard starts. Follow its instructions - pick the [Rmin] a [Rmax] values from the ratio graph.
7) The [Ca2+] graph display becomes available to be displayed in the time measurement window.
8) The [Ca2+] image channel view is created within the ND2 document. It visualizes the Ca2+ ion con-

centration via a color scale.
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Ratio View Properties - Calcium Calibration settings

If you prefer to modify the Calcium Calibration by hand, run the [View > Ratio Properties] command. In
the window that appears select the [Use Ca2+ calibration] check box (or it is already selected if the calib-
ration procedure was performed beforehand). The [Calcium Calibration] tab appears.

All constants necessary for calcium ion concentration calculation can be defined manually within the [Ratio
Properties] window, either for each ROI separately or globally (the [Use per ROI Calibration] option). Use
the [Pick values from the time graph] to pick [R min/max] constants from the [Time Measurement]
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graph - the timemeasurementmust have been performed before. The [Fmin/max] values will be computed
automatically.

[Ca2+]
Concentration of Calcium in nanoMoles.

Kd
Dissociation constant: 135nM at 20ºC, 224nM at 37ºC

Fmin
The 380 intensity in the moment of [R min].

Fmax
The 380 intensity in the moment of [R max].

R
Ratio of 340/380 intensity at the current time point

viscosity
“Constant” between 0.7 and 1.

Rmin
The minimum ratio value of the experiment

Rmax
The maximum ratio value of the experiment

The calibration settings can be saved for further use by the [Save] button (and loaded later by the [Load]
button).
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10.11. The Advanced Interpreter (API) Module
This module dramatically extends the macro programing capabilities. It adds the following functionality to
the main application:

User interaction functions
Contains functions, which enable an interaction with user like: type value, text, combo boxes, list boxes
and many other Windows standard controls with easy and intuitive code handling.

Support of importing functions from external DLLs
Functions from external DLLs can be imported at the start of the macro and used during the macro ex-
ecution.
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